summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm32
1 files changed, 12 insertions, 20 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 39d83336fd..acdee6f689 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016 Carlo Zancanaro <carlo@zancanaro.id.au>
-;;; Copyright © 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016, 2017, 2018, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2020 Nikita <nikita@n0.is>
;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
;;; Copyright © 2016 Ivan Vilata i Balaguer <ivan@selidor.net>
@@ -651,14 +651,10 @@ Features include:
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(icons (string-append out "/share/i3lock-fancy/icons/"))
- (wmctrl (string-append (assoc-ref inputs "wmctrl")
- "/bin/wmctrl"))
- (mconvert (string-append (assoc-ref inputs "imagemagick")
- "/bin/convert"))
- (mimport (string-append (assoc-ref inputs "imagemagick")
- "/bin/import"))
- (awk (string-append (assoc-ref inputs "gawk")
- "/bin/gawk")))
+ (wmctrl (search-input-file inputs "/bin/wmctrl"))
+ (mconvert (search-input-file inputs "/bin/convert"))
+ (mimport (search-input-file inputs "/bin/import"))
+ (awk (search-input-file inputs "/bin/gawk")))
(substitute* "lock"
(("\\$\\(command -V wmctrl\\)") wmctrl)
@@ -969,9 +965,7 @@ experience.")
(base32
"1xaz13iry3fdjhqk9xzg29kbv7hqj8dzzqxr5mhrj8f2m013jdc3"))))
(build-system meson-build-system)
- (arguments
- `( #:meson ,meson-0.55
- #:build-type "release"))
+ (arguments `(#:build-type "release"))
(native-inputs
`(("pkg-config" ,pkg-config)
("wayland-protocols" ,wayland-protocols)
@@ -1473,7 +1467,7 @@ functionality to display information about the most commonly used services.")
(define-public wlroots
(package
(name "wlroots")
- (version "0.12.0")
+ (version "0.13.0")
(source
(origin
(method git-fetch)
@@ -1482,11 +1476,10 @@ functionality to display information about the most commonly used services.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "01j38lmgs2c6fq68v8b75pkilia2wsgzgp46ivfbi9hhx47kgcfn"))))
+ (base32 "01plhbnsp5yg18arz0v8fr0pr9l4w4pdzwkg9px486qdvb3s1vgy"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dlogind-provider=elogind")
- #:meson ,meson-0.55
#:phases
(modify-phases %standard-phases
(add-before 'configure 'hardcode-paths
@@ -1521,7 +1514,7 @@ modules for building a Wayland compositor.")
(define-public sway
(package
(name "sway")
- (version "1.5.1")
+ (version "1.6")
(source
(origin
(method git-fetch)
@@ -1530,7 +1523,7 @@ modules for building a Wayland compositor.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1xsa3h8zhf29p0mi90baxpr76jkd9pd1gr97ky8cnjbcs4isj9j0"))))
+ (base32 "0vnplva11yafhbijrk68wy7pw0psn9jm0caaymswq1s951xsn1c8"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -1698,7 +1691,7 @@ display a clock or apply image manipulation techniques to the background image."
(inputs `(("date" ,date)
("fmt" ,fmt)
("gtk-layer-shell" ,gtk-layer-shell)
- ("gtkmm" ,gtkmm)
+ ("gtkmm" ,gtkmm-3)
("jsoncpp" ,jsoncpp)
("libdbusmenu" ,libdbusmenu)
("libinput" ,libinput)
@@ -1708,8 +1701,7 @@ display a clock or apply image manipulation techniques to the background image."
("spdlog" ,spdlog)
("wayland" ,wayland)))
(native-inputs
- `(("gcc" ,gcc-8) ; for #include <filesystem>
- ("glib:bin" ,glib "bin")
+ `(("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)
("scdoc" ,scdoc)
("wayland-protocols" ,wayland-protocols)))