summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index dc32832860..e5314e1a03 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1391,7 +1391,7 @@ functionality to display information about the most commonly used services.")
(define-public wlroots
(package
(name "wlroots")
- (version "0.12.0")
+ (version "0.13.0")
(source
(origin
(method git-fetch)
@@ -1400,11 +1400,11 @@ functionality to display information about the most commonly used services.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "01j38lmgs2c6fq68v8b75pkilia2wsgzgp46ivfbi9hhx47kgcfn"))))
+ (base32 "01plhbnsp5yg18arz0v8fr0pr9l4w4pdzwkg9px486qdvb3s1vgy"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dlogind-provider=elogind")
- #:meson ,meson-0.55
+ #:meson ,meson-next
#:phases
(modify-phases %standard-phases
(add-before 'configure 'hardcode-paths
@@ -1439,7 +1439,7 @@ modules for building a Wayland compositor.")
(define-public sway
(package
(name "sway")
- (version "1.5.1")
+ (version "1.6")
(source
(origin
(method git-fetch)
@@ -1448,10 +1448,11 @@ modules for building a Wayland compositor.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1xsa3h8zhf29p0mi90baxpr76jkd9pd1gr97ky8cnjbcs4isj9j0"))))
+ (base32 "0vnplva11yafhbijrk68wy7pw0psn9jm0caaymswq1s951xsn1c8"))))
(build-system meson-build-system)
(arguments
- `(#:phases
+ `(#:meson ,meson-next
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'hardcode-paths
(lambda* (#:key inputs #:allow-other-keys)
@@ -1594,8 +1595,7 @@ modules for building a Wayland compositor.")
("spdlog" ,spdlog)
("wayland" ,wayland)))
(native-inputs
- `(("gcc" ,gcc-8) ; for #include <filesystem>
- ("glib:bin" ,glib "bin")
+ `(("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)
("scdoc" ,scdoc)
("wayland-protocols" ,wayland-protocols)))