summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index e54b680855..7384ead14b 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -295,11 +295,6 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
(("libWPEBackend-fdo-([\\.0-9]+)\\.so" all version)
(string-append wpebackend-fdo "/lib/" all)))
#t)))
- (add-before 'configure 'prepare-build-environment
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "CC" "clang")
- (setenv "CXX" "clang++")
- #t))
(add-after 'install 'move-doc-files
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -309,8 +304,8 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
(string-append doc "/share/gtk-doc"))
#t))))))
(native-inputs
- `(("clang" ,clang-11)
- ("bison" ,bison)
+ `(("bison" ,bison)
+ ("gcc" ,gcc-11)
("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection)