summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm40
1 files changed, 4 insertions, 36 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 2eca5147fe..ea7cee54e3 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -59,14 +59,14 @@
(define-public webkitgtk
(package
(name "webkitgtk")
- (version "2.20.5")
+ (version "2.24.4")
(source (origin
(method url-fetch)
(uri (string-append "https://www.webkitgtk.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "147r7an41920zl4x9srdva7fxvw2znjin5ldjkhay1cndv9gih0m"))))
+ "1n3x5g1z6rg9n1ssna7wi0z6zlprjm4wzk544v14wqi6q0lv2s46"))))
(build-system cmake-build-system)
(outputs '("out" "doc"))
(arguments
@@ -119,7 +119,7 @@
("gperf" ,gperf)
("perl" ,perl)
("pkg-config" ,pkg-config)
- ("python" ,python-2) ; incompatible with Python 3 (print syntax)
+ ("python" ,python-wrapper)
("gtk-doc" ,gtk-doc) ; For documentation generation
("docbook-xml" ,docbook-xml) ; For documentation generation
("ruby" ,ruby)))
@@ -147,6 +147,7 @@
("libxslt" ,libxslt)
("libxt" ,libxt)
("mesa" ,mesa)
+ ("openjpeg" ,openjpeg)
("sqlite" ,sqlite)))
(home-page "https://www.webkitgtk.org/")
(synopsis "Web content engine for GTK+")
@@ -160,36 +161,3 @@ HTML/CSS applications to full-fledged web browsers.")
license:lgpl2.1+
license:bsd-2
license:bsd-3))))
-
-;; This version of webkitgtk needs to be kept separate, because it requires a
-;; newer version of GCC than our default compiler, and this causes problems
-;; when linked with C++ libraries built using our default compiler. For now,
-;; we use this newer webkitgtk only for selected packages, e.g. epiphany.
-(define-public webkitgtk-2.24
- (package/inherit webkitgtk
- (name "webkitgtk")
- (version "2.24.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://www.webkitgtk.org/releases/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1n3x5g1z6rg9n1ssna7wi0z6zlprjm4wzk544v14wqi6q0lv2s46"))))
- (native-inputs
- `(("gcc" ,gcc-7) ; webkitgtk-2.22 requires gcc-6 or newer
- ,@(package-native-inputs webkitgtk)))
- (inputs
- `(("openjpeg" ,openjpeg)
- ,@(package-inputs webkitgtk)))
- (arguments
- (substitute-keyword-arguments (package-arguments webkitgtk)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-before 'configure 'work-around-gcc-7-include-path-issue
- ;; FIXME: Work around a problem with gcc-7 includes (see
- ;; <https://bugs.gnu.org/30756>).
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))))))))