summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm90
1 files changed, 68 insertions, 22 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3d73bfec2b..cd83613c6e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -35,6 +35,8 @@
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;;
@@ -107,6 +109,7 @@
#:use-module (gnu packages jemalloc)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages kde)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libunistring)
@@ -830,6 +833,50 @@ instances, while JSON's objects will be mapped to @code{QVariantMap}.")
;; Only version 2.1 of the license
(license license:lgpl2.1)))
+(define-public qoauth
+ (package
+ (name "qoauth")
+ (version "2.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ayoy/qoauth.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1b2jdqs526ac635yb2whm049spcsk7almnnr6r5b4yqhq922anw3"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("qca" ,qca)
+ ("qtbase" ,qtbase)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-code
+ (lambda _
+ (make-file-writable "src/qoauth.pc")
+ (substitute* "src/src.pro"
+ (("/lib64") "/lib"))
+ #t))
+ (delete 'configure) ; no configure script
+ (delete 'check) ; no test target
+ (add-before 'build 'qmake
+ (lambda _
+ (let ((qca (assoc-ref %build-inputs "qca")))
+ (invoke
+ "qmake"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "QMAKE_INCDIR+=" qca "/include/Qca-qt5/QtCrypto")
+ (string-append "LIBS+=-L" qca "/lib")
+ (string-append "LIBS+=-lqca-qt5"))))))))
+ (home-page "https://github.com/ayoy/qoauth")
+ (synopsis "Qt-based C++ library for OAuth authorization scheme")
+ (description "QOAuth is an attempt to support interaction with
+OAuth-powered network services in a Qt way, i.e. simply, clearly and
+efficiently. It gives the application developer no more than 4 methods.")
+ (license license:lgpl2.1+)))
+
(define-public krona-tools
(package
(name "krona-tools")
@@ -5031,7 +5078,7 @@ w3c webidl files and a binding configuration file.")
("openssl" ,openssl)
("utf8proc" ,utf8proc)
("libpng" ,libpng)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libcss" ,libcss)
("libdom" ,libdom)
("libnsbmp" ,libnsbmp)
@@ -5635,10 +5682,22 @@ into your tests. It automatically starts up a HTTP server in a separate thread
#:make-flags
(list (string-append "PREFIX="
(assoc-ref %outputs "out"))
- "CC=gcc" "library")
+ "library"
+ ,@(if (%current-target-system)
+ '()
+ '("CC=gcc")))
#:phases
(modify-phases %standard-phases
- (delete 'configure))))
+ ,@(if (%current-target-system)
+ '((replace 'configure
+ (lambda* (#:key target #:allow-other-keys)
+ (substitute* (find-files "." "Makefile")
+ (("CC\\?=.*$")
+ (string-append "CC=" target "-gcc\n"))
+ (("AR\\?=.*$")
+ (string-append "AR=" target "-ar\n")))
+ #t)))
+ '((delete 'configure))))))
(synopsis "HTTP request/response parser for C")
(description "This is a parser for HTTP messages written in C. It parses
both requests and responses. The parser is designed to be used in
@@ -6838,8 +6897,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
(define-public nghttp2
(package
(name "nghttp2")
- (version "1.39.1")
- (replacement nghttp2-1.39.2)
+ (version "1.40.0")
(source
(origin
(method url-fetch)
@@ -6848,7 +6906,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
"nghttp2-" version ".tar.xz"))
(sha256
(base32
- "0j0lk37k8k3f61r9nw647hg4b22z1753l36n3xrp9x01civ614b7"))))
+ "0wwhwv7cvi1vxpdjwvg0kpa4jzhszclpnwrwfcw728zz53a47z09"))))
(build-system gnu-build-system)
(outputs (list "out"
"lib")) ; only libnghttp2
@@ -6886,9 +6944,10 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
(assoc-ref outputs "lib")))
#t))
(add-before 'check 'set-timezone-directory
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "TZDIR" (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo"))
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (setenv "TZDIR" (string-append
+ (assoc-ref (or native-inputs inputs) "tzdata")
+ "/share/zoneinfo"))
#t)))))
(home-page "https://nghttp2.org/")
(synopsis "HTTP/2 protocol client, proxy, server, and library")
@@ -6917,19 +6976,6 @@ compressed JSON header blocks.
@end itemize\n")
(license license:expat)))
-(define nghttp2-1.39.2
- (package
- (inherit nghttp2)
- (version "1.39.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/nghttp2/nghttp2/"
- "releases/download/v" version "/"
- "nghttp2-" version ".tar.xz"))
- (sha256
- (base32
- "12yfsjghbaypp4w964d45ih9vs38g6anih80wbsflaxx192idlm2"))))))
-
(define-public hpcguix-web
(let ((commit "f39c90b35e99e4122b0866ec4337020d61c81508")
(revision "4"))