summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 134cac1c9a..1587734ee6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4886,10 +4886,14 @@ It uses the uwsgi protocol for all the networking/interprocess communications.")
(inputs
(list oniguruma))
(native-inputs
- (list ;; TODO fix gems to generate documentation
- ;;("ruby" ,ruby)
- ;;("bundler" ,bundler)
- valgrind))
+ (append
+ ;; TODO: fix gems to generate documentation
+ ;(list ruby bundler)
+ '()
+ (if (member (%current-system)
+ (package-supported-systems valgrind))
+ (list valgrind)
+ '())))
(build-system gnu-build-system)
(home-page "https://stedolan.github.io/jq/")
(synopsis "Command-line JSON processor")