summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm69
1 files changed, 41 insertions, 28 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8bb02ee887..7ea3217481 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -40,17 +40,19 @@
;;; Copyright © 2019, 2020 Florian Pelz <pelzflorian@pelzflorian.de>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020, 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018, 2019, 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020, 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020, 2021 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
@@ -1010,8 +1012,8 @@ and UNIX socket support.")
(arguments
`(#:configure-flags
(list "--disable-plugin" ;NPAPI plugins are obsolete nowadays.
- (string-append "BIN_BASH=" (assoc-ref %build-inputs "bash")
- "/bin/bash")
+ (string-append "BIN_BASH="
+ (search-input-file %build-inputs "/bin/bash"))
(string-append "--with-jdk-home=" (assoc-ref %build-inputs "jdk")))))
(outputs '("out" "doc"))
(native-inputs
@@ -1033,7 +1035,7 @@ libraries for working with JNLP applets.")
(define-public jansson
(package
(name "jansson")
- (version "2.12")
+ (version "2.13.1")
(source (origin
(method url-fetch)
(uri
@@ -1041,7 +1043,7 @@ libraries for working with JNLP applets.")
version ".tar.bz2"))
(sha256
(base32
- "1lp1mv8pjp5yziws66cy0dhpcam4bbjqhffk13v4vgdybp674pb4"))))
+ "1g8h18vh8gyxlwfmvdivdp1siad26ywj5zr4j4avgdyjg7wa147f"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-static")))
@@ -1055,7 +1057,7 @@ data.")
(define-public json-c
(package
(name "json-c")
- (version "0.14")
+ (version "0.15")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1063,8 +1065,7 @@ data.")
version ".tar.gz"))
(sha256
(base32
- "0w381krr99q5a2rypx4g437fa7gzgl82i64sgnrs6g5jr44dwxxk"))
- (patches (search-patches "json-c-CVE-2020-12762.patch"))))
+ "1im484iz08j3gmzpw07v16brwq46pxxj65i996kkp2vivcfhmn5q"))))
(build-system cmake-build-system)
(home-page "https://github.com/json-c/json-c/wiki")
(synopsis "JSON implementation in C")
@@ -3886,16 +3887,14 @@ and IPv6 sockets, intended as a replacement for IO::Socket::INET.")
(define-public perl-io-socket-ssl
(package
(name "perl-io-socket-ssl")
- (version "2.066")
+ (version "2.068")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/S/SU/SULLR/"
"IO-Socket-SSL-" version ".tar.gz"))
(sha256
(base32
- "1kgbws7dwp2hh16qid7169dfkhmcwg7dz9ffbm6k0id5h53hciqd"))
- (patches (search-patches
- "perl-io-socket-ssl-openssl-1.0.2f-fix.patch"))))
+ "1ycgzg1l7p07y5wc0vzgnj122vm51p5aqpi4s56pp0piaq0gq824"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-net-ssleay" ,perl-net-ssleay)
@@ -4515,14 +4514,14 @@ applications.")
(define-public perl-uri
(package
(name "perl-uri")
- (version "1.76")
+ (version "5.05")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/O/OA/OALDERS/"
"URI-" version ".tar.gz"))
(sha256
(base32
- "0gj1aj18k43kmzc3y1zhj5giinf8rksacf757r475xfna0fqxjdj"))))
+ "1v3r3ck67w272kzfgm1nd3wb41av1hlnza56vkxxj1i7s3917hd5"))))
(build-system perl-build-system)
(native-inputs
;; For tests.
@@ -4765,14 +4764,14 @@ their web site.")
(define-public python-feedparser
(package
(name "python-feedparser")
- (version "6.0.2")
+ (version "6.0.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "feedparser" version ".tar.gz"))
(sha256
(base32
- "0x0hm9brh3j71645pydvlkrwxaaca9dnwd7xahwjyjaz882s200v"))))
+ "0qcnkyjjfj5gg5rhd1j4zzlqx5h34bma18zwgj68q95b0l543q2w"))))
(build-system python-build-system)
(propagated-inputs
`(("python-sgmllib3k" ,python-sgmllib3k)))
@@ -5094,7 +5093,13 @@ fast and flexible way of exploring HTML from the terminal.")
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("pkg-config" ,pkg-config)))
(inputs
- `(("libsoup" ,libsoup)))
+ `(("libsoup" ,libsoup-minimal-2)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-home-for-tests
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
(home-page "https://gitlab.com/groups/uhttpmock")
(synopsis "Library for mocking web service APIs which use HTTP or HTTPS")
(description
@@ -5392,7 +5397,13 @@ developed as part of the Netsurf project.")
"libcss-" version "-src.tar.gz"))
(sha256
(base32
- "1p66sdiiqm7w4jkq23hsf08khsnmq93hshh9f9m8sbirjdpf3p6j"))))
+ "1p66sdiiqm7w4jkq23hsf08khsnmq93hshh9f9m8sbirjdpf3p6j"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; This can be removed with the next release.
+ (substitute* "src/select/computed.c"
+ (("css_unit unit;") "css_unit unit = CSS_UNIT_PX;"))))))
(build-system gnu-build-system)
(native-inputs
`(("netsurf-buildsystem" ,netsurf-buildsystem)
@@ -5723,7 +5734,7 @@ w3c webidl files and a binding configuration file.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* '("test/bloom.c" "test/hashtable.c")
(("/usr/share/dict/words")
- (string-append (assoc-ref inputs "miscfiles") "/share/web2")))
+ (search-input-file inputs "/share/web2")))
#t))
(add-after 'install 'install-more
(lambda* (#:key outputs #:allow-other-keys)
@@ -6380,13 +6391,13 @@ message stream (in a web server that is per connection).")
(define-public python-httpretty
(package
(name "python-httpretty")
- (version "1.0.5")
+ (version "1.1.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "httpretty" version))
(sha256
- (base32 "1dg0nfl7i9kjnq98ww98x2afzav4mpgiwzvjc43ily1x9my94g75"))))
+ (base32 "0s1vjdaf3pk2xd0hvi5f7p3jm2rgwpbc734jdp9r50m1smfhxpi0"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; Tests require network access.
@@ -6395,8 +6406,7 @@ message stream (in a web server that is per connection).")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "nosetests"))
- #t)))))
+ (invoke "nosetests")))))))
(native-inputs
`(("python-coverage" ,python-coverage)
("python-eventlet" ,python-eventlet)
@@ -6610,9 +6620,8 @@ Instagram and YouTube.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (add-installed-pythonpath inputs outputs)
(invoke "py.test" "tests")))))))
(home-page "https://linkchecker.github.io/linkchecker/")
(synopsis "Check websites for broken links")
@@ -7583,7 +7592,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
(define-public nghttp2
(package
(name "nghttp2")
- (version "1.41.0")
+ (version "1.44.0")
(source
(origin
(method url-fetch)
@@ -7592,7 +7601,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
"nghttp2-" version ".tar.xz"))
(sha256
(base32
- "1hk77vngjmvvzb5y1gi1aqwf6qywrc7yak08zvzb7x81qs6mphmb"))))
+ "0p9wvva4g8hwj55x19rbyvnq2dbsnf65rphhxnpqs7ll54xlg6an"))))
(build-system gnu-build-system)
(outputs (list "out"
"lib")) ; only libnghttp2
@@ -7601,6 +7610,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
;; Required by tests.
("cunit" ,cunit)
+ ("python" ,python)
("tzdata" ,tzdata-for-tests)))
(inputs
;; Required to build the tools (i.e. without ‘--enable-lib-only’).
@@ -7620,7 +7630,10 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
"--enable-app" ; build all the tools
"--enable-hpack-tools" ; ...all the tools
"--disable-examples"
- "--disable-static") ; don't bother building .a files
+ "--disable-static" ; don't bother building .a files
+ ,@(if (%current-target-system)
+ '("--disable-python-bindings")
+ '()))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'break-circular-reference