summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm352
1 files changed, 260 insertions, 92 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 13ae53aa8c..aab3ae1839 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1,12 +1,12 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
-;;; Copyright © 2014-2023 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014-2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015-2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015-2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2015-2020, 2024 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
@@ -46,7 +46,7 @@
;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020, 2021 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
-;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
@@ -65,6 +65,7 @@
;;; Copyright © 2023 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
+;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -118,8 +119,11 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
- #:use-module (gnu packages crates-gtk)
+ #:use-module (gnu packages crates-crypto)
#:use-module (gnu packages crates-io)
+ #:use-module (gnu packages crates-gtk)
+ #:use-module (gnu packages crates-tls)
+ #:use-module (gnu packages crates-web)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages databases)
@@ -142,7 +146,10 @@
#:use-module (gnu packages gnunet)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-check)
#:use-module (gnu packages golang-web)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gperf)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
@@ -1102,40 +1109,44 @@ APIs.")
(license (license:non-copyleft "file://LICENSE.TERMS"))))
(define-public fcgiwrap
- (package
- (name "fcgiwrap")
- (version "1.1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gnosek/fcgiwrap")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1ryw66h9aazi83amk8l7ha8k5g0c7qvk5g6jv376a1ws9xk2qw6f"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no tests included
- #:make-flags (list "CC=gcc")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-CFLAGS
- ;; Remove broken options unconditionally added to CFLAGS.
- (lambda _
- (substitute* "configure.ac"
- ((" -Werror") ""))
- #t)))))
- (native-inputs
- (list autoconf automake pkg-config))
- (inputs
- (list fcgi))
- (home-page "https://nginx.localdomain.pl/wiki/FcgiWrap")
- (synopsis "Simple server for running CGI applications over FastCGI")
- (description "Fcgiwrap is a simple server for running CGI applications
+ (let ((commit "2870d2729a3930988f0041e2d78fec672e69afac")
+ (revision "1"))
+ (package
+ (name "fcgiwrap")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; Upstream last updated in 2015, this forked version has better
+ ;; socket cleanup.
+ (url "https://github.com/flu0r1ne/fcgiwrap")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rkpp4apfhdcrmym3pcpqlncd0r4fyr3pa45i8g6x4p38b4azmmm"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:make-flags (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-CFLAGS
+ ;; Remove broken options unconditionally added to CFLAGS.
+ (lambda _
+ (substitute* "configure.ac"
+ ((" -Werror") ""))
+ #t)))))
+ (native-inputs
+ (list autoconf automake pkg-config))
+ (inputs
+ (list fcgi))
+ (home-page "https://nginx.localdomain.pl/wiki/FcgiWrap")
+ (synopsis "Simple server for running CGI applications over FastCGI")
+ (description "Fcgiwrap is a simple server for running CGI applications
over FastCGI. It hopes to provide clean CGI support to Nginx (and other web
servers that may need it).")
- (license license:expat)))
+ (license license:expat))))
(define-public starman
(package
@@ -1481,7 +1492,7 @@ efficiently. It gives the application developer no more than 4 methods.")
"ImportTaxonomy"
"ImportText"
"ImportXML"))
- (for-each
+ (for-each
(lambda (directory)
(copy-recursively directory
(string-append perl "/../" directory)))
@@ -1637,7 +1648,7 @@ for efficient socket-like bidirectional reliable communication channels.")
(define-public wabt
(package
(name "wabt")
- (version "1.0.32")
+ (version "1.0.34")
(source
(origin
(method git-fetch)
@@ -1647,13 +1658,15 @@ for efficient socket-like bidirectional reliable communication channels.")
(recursive? #true)))
(file-name (git-file-name name version))
(sha256
- (base32 "0m124r8v9c0hxiaa4iy7ch4ng8msnirbc2vb702gbdjhvgzyrcwh"))
+ (base32 "1vxvc34b7a7lkrmzdb5cjv0b54vhiyr33sy0i2ps5jrmg5rqqmia"))
(modules '((guix build utils)))
(snippet
'(delete-file-recursively "third_party/gtest/"))))
(build-system cmake-build-system)
(arguments
(list
+ ;; Tests on non-x86_64 architectures are not well supported upstream.
+ #:tests? (target-x86-64?)
#:test-target "run-tests"
#:configure-flags '(list "-DUSE_SYSTEM_GTEST=ON")
#:phases
@@ -4884,9 +4897,40 @@ their web site.")
"1p5i8wsi8q5fpq63i7n7ri1w1lnh4gpn17f88vhkbh14aah5wxj1"))))
(properties '(("upstream-name" . "python-lambda-4dn")))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-pip-install
+ (lambda _
+ (substitute* "aws_lambda/aws_lambda.py"
+ ;; This package uses pip to install Python packages, wrap them
+ ;; up, and push them to AWS Lambda. We need to reset
+ ;; GUIX_PYTHONPATH to avoid introducing package conflicts that
+ ;; would cause pip to fail.
+ (("(subprocess.call\\(\\[sys.executable.*'--no-cache-dir'\\])\\)" _ m)
+ (string-append m ", env={\"GUIX_PYTHONPATH\":\""
+ #$(this-package-input "python")
+ "/lib/python"
+ #$(version-major+minor
+ (package-version (this-package-input "python")))
+ "/site-packages/\"})"))
+ ;; Zipfile uses the mtime of the temporary directory to build
+ ;; a zip file. But the temp directory has a timestamp of 0,
+ ;; and zipfile refuses to build a zip archive dated before
+ ;; 1980. So we reset the mtime of all temp files before they
+ ;; are added to the zip archive.
+ (("^( +)arcname = os.path.join" line indent)
+ (string-append indent
+ "os.utime(os.path.join(root, file), (315619200, 315619200))\n"
+ line))))))))
+ (inputs (list python))
(propagated-inputs
- (list python-boto3 python-botocore python-docutils
- python-six))
+ (list python-boto3
+ python-botocore
+ python-docutils
+ python-six
+ python-virtualenv))
(home-page "https://github.com/4dn-dcic/python-lambda")
(synopsis
"Toolkit for developing and deploying Python code in AWS Lambda")
@@ -4958,8 +5002,8 @@ Cloud.")
(license license:expat)))
(define-public guix-data-service
- (let ((commit "e13febc81706fbfb7f073bc4e9ce73fbc80d5180")
- (revision "44"))
+ (let ((commit "b4583bb17714954530e1cc851efaea1666f6adc2")
+ (revision "46"))
(package
(name "guix-data-service")
(version (string-append "0.0.1-" revision "." (string-take commit 7)))
@@ -4971,7 +5015,7 @@ Cloud.")
(file-name (git-file-name name version))
(sha256
(base32
- "0pk86b44zg2yn73sxlcd9pqbz8xwprwzaib2npnq80y3yzc6qc22"))))
+ "0l9nflx5npmmbvqxrfjhfvyr7mcs9qrf0w3dabs65r7q0g0pjcp0"))))
(build-system gnu-build-system)
(arguments
(list
@@ -5195,6 +5239,69 @@ little effort, and the program to do so is often shorter and simpler than
you'd expect.")
(license (list license:expat license:cc-by3.0))))
+(define-public go-github-com-mikefarah-yq-v4
+ (package
+ (name "go-github-com-mikefarah-yq-v4")
+ (version "4.34.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mikefarah/yq")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y5i0p4fiq0kad9xqihhyclhd9d3l2r5yligdkvsdc90hlqjmql3"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/mikefarah/yq/v4"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'remove-binary
+ (lambda _
+ (delete-file-recursively
+ (string-append #$output "/bin")))))))
+ (propagated-inputs
+ (list go-github-com-a8m-envsubst
+ go-github-com-alecthomas-participle-v2
+ go-github-com-dimchansky-utfbom
+ go-github-com-elliotchance-orderedmap
+ go-github-com-fatih-color
+ go-github-com-goccy-go-json
+ go-github-com-goccy-yaml
+ go-github-com-jinzhu-copier
+ go-github-com-magiconair-properties
+ go-github-com-pelletier-go-toml-v2
+ go-github-com-spf13-cobra
+ go-golang-org-x-net
+ go-golang-org-x-text
+ go-gopkg-in-op-go-logging-v1
+ go-gopkg-in-yaml-v3))
+ (home-page "https://mikefarah.gitbook.io/yq/")
+ (synopsis
+ "Command-line YAML, JSON, XML, CSV, TOML and properties processor")
+ (description
+ "This package provides @code{yq}, a command-line YAML, JSON and XML
+processor. It uses @code{jq}-like syntax but works with YAML files as well as
+JSON, XML, properties, CSV and TSV.")
+ (license license:expat)))
+
+(define-public yq
+ (package
+ (inherit go-github-com-mikefarah-yq-v4)
+ (name "yq")
+ (arguments
+ (list #:install-source? #f
+ #:import-path "github.com/mikefarah/yq/v4"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'rename-binary
+ (lambda _
+ (rename-file (string-append #$output "/bin/v4")
+ (string-append #$output "/bin/yq")))))))
+ (propagated-inputs '())
+ (inputs (package-propagated-inputs go-github-com-mikefarah-yq-v4))))
+
(define-public go-github-com-itchyny-timefmt-go
(package
(name "go-github-com-itchyny-timefmt-go")
@@ -5356,7 +5463,7 @@ tools they trust (e.g. wget).")
(define netsurf-buildsystem
(package
(name "netsurf-buildsystem")
- (version "1.9")
+ (version "1.10")
(source
(origin
(method url-fetch)
@@ -5364,7 +5471,7 @@ tools they trust (e.g. wget).")
"buildsystem-" version ".tar.gz"))
(sha256
(base32
- "0alsmaig9ln8dgllb3z63gq90fiz75jz0ic71fi0k0k898qix14k"))))
+ "0yadmrpgvl9r08b56qiy5f77jracc7g9n4krn727fip4d7akjgix"))))
(build-system gnu-build-system)
(inputs `(("perl" ,perl)))
(arguments
@@ -5395,7 +5502,7 @@ libraries.")
(define-public libparserutils
(package
(name "libparserutils")
- (version "0.2.4")
+ (version "0.2.5")
(source
(origin
(method url-fetch)
@@ -5403,7 +5510,7 @@ libraries.")
name "-" version "-src.tar.gz"))
(sha256
(base32
- "1n2794y2l0c8nv8z2pxwfnbn882987ifmxjv60zdxkhcndhswarj"))))
+ "0ffi5q1jlcdl66nk3cax0mnzvhrjvvjvlx0rfasjfygi333xazii"))))
(build-system gnu-build-system)
(native-inputs
(list netsurf-buildsystem pkg-config perl)) ;for test harness
@@ -5418,7 +5525,7 @@ C. It is developed as part of the NetSurf project.")
(define-public hubbub
(package
(name "hubbub")
- (version "0.3.7")
+ (version "0.3.8")
(source
(origin
(method url-fetch)
@@ -5426,15 +5533,14 @@ C. It is developed as part of the NetSurf project.")
"libhubbub-" version "-src.tar.gz"))
(sha256
(base32
- "1dimfyblmym98qa1b80c5jslv2zk8r44xbdrgrsrw1n9wr9y4yly"))
- (patches (search-patches
- "hubbub-sort-entities.patch"
- "hubbub-maybe-uninitialized.patch"))))
+ "19fm5h8arnsgxd4w5vr9s2fcb422acciffar3la0b36lygsydhca"))
+ (patches (search-patches "hubbub-sort-entities.patch"))))
(build-system gnu-build-system)
(native-inputs
(list netsurf-buildsystem
pkg-config
doxygen
+ gperf
json-c-0.12 ; check whether json-c-0.12 can be removed
perl))
(propagated-inputs
@@ -5602,7 +5708,7 @@ developed as part of the Netsurf project.")
(define-public libcss
(package
(name "libcss")
- (version "0.9.1")
+ (version "0.9.2")
(source
(origin
(method url-fetch)
@@ -5610,13 +5716,8 @@ developed as part of the Netsurf project.")
"libcss-" version "-src.tar.gz"))
(sha256
(base32
- "1p66sdiiqm7w4jkq23hsf08khsnmq93hshh9f9m8sbirjdpf3p6j"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; This can be removed with the next release.
- (substitute* "src/select/computed.c"
- (("css_unit unit;") "css_unit unit = CSS_UNIT_PX;"))))))
+ "0khmf5bdpkc09fpsgwzi23sihpadvyr02jx0q5h1vm9lxjxibwid"))
+ (patches (search-patches "libcss-check-format.patch"))))
(build-system gnu-build-system)
(native-inputs
(list netsurf-buildsystem pkg-config perl))
@@ -5633,7 +5734,7 @@ written in C. It is developed as part of the NetSurf project.")
(define-public libdom
(package
(name "libdom")
- (version "0.4.1")
+ (version "0.4.2") ;TODO include patch for additional tags?
(source
(origin
(method url-fetch)
@@ -5641,7 +5742,7 @@ written in C. It is developed as part of the NetSurf project.")
"libdom-" version "-src.tar.gz"))
(sha256
(base32
- "0jpg5hx3y0mdxk5szd47dyijqimd2321brbqk2620pp5f4j0gvlq"))))
+ "0g0gqcglk8f8gbygbcq5ylcx84zsf0vczbm3n3118w2l2splapnh"))))
(build-system gnu-build-system)
(native-inputs
(list netsurf-buildsystem
@@ -5668,7 +5769,7 @@ developed as part of the NetSurf project.")
(define-public libsvgtiny
(package
(name "libsvgtiny")
- (version "0.1.7")
+ (version "0.1.8")
(source
(origin
(method url-fetch)
@@ -5676,7 +5777,7 @@ developed as part of the NetSurf project.")
name "-" version "-src.tar.gz"))
(sha256
(base32
- "10bpkmvfpydj74im3r6kqm9vnvgib6afy0alx71q5n0w5yawy39c"))))
+ "0750q884ax8wygl64wq03zdjj8h838ch3f8jdfkv4gz809zj4my3"))))
(build-system gnu-build-system)
(native-inputs
(list netsurf-buildsystem pkg-config gperf-3.0))
@@ -5697,7 +5798,7 @@ project.")
(define-public libnsbmp
(package
(name "libnsbmp")
- (version "0.1.6")
+ (version "0.1.7")
(source
(origin
(method url-fetch)
@@ -5705,7 +5806,7 @@ project.")
name "-" version "-src.tar.gz"))
(sha256
(base32
- "0krjg69a2amxjsahdgm3wmy9ngnyr3gfs2a1zhdlbvb0z1jr7i3r"))))
+ "14r2v1ich4lxn3sdwpiwq5adydrd1qlhbd8mbamalaqj59laf1sl"))))
(build-system gnu-build-system)
(native-inputs
(list netsurf-buildsystem))
@@ -5753,7 +5854,7 @@ operations.")
(define-public libnsgif
(package
(name "libnsgif")
- (version "0.2.1")
+ (version "1.0.0")
(source
(origin
(method url-fetch)
@@ -5761,7 +5862,7 @@ operations.")
name "-" version "-src.tar.gz"))
(sha256
(base32
- "0jwshypgmx16xlsbx3d8njk8a5khazlplca5mxd3rdbhrlsabbly"))))
+ "06q69hn0nz3c6hnwmzfcldyrppkvimx3s97ql3sx4m0lyr1ch530"))))
(build-system gnu-build-system)
(native-inputs
(list netsurf-buildsystem))
@@ -5804,7 +5905,7 @@ client applications. It is developed as part of the NetSurf project.")
(define-public libnsutils
(package
(name "libnsutils")
- (version "0.1.0")
+ (version "0.1.1")
(source
(origin
(method url-fetch)
@@ -5812,7 +5913,7 @@ client applications. It is developed as part of the NetSurf project.")
name "-" version "-src.tar.gz"))
(sha256
(base32
- "1w5fyy2i60a3v3if3iqcn9sy9sycx6966rcx53v85gja6hb6a33r"))))
+ "14pakllwf7a205d0dkvyg8jhmqfbi5sh5riw840d13j5dr9b952n"))))
(build-system gnu-build-system)
(native-inputs
(list netsurf-buildsystem))
@@ -5827,7 +5928,7 @@ developed as part of the NetSurf project.")
(define-public libnspsl
(package
(name "libnspsl")
- (version "0.1.6")
+ (version "0.1.7")
(source
(origin
(method url-fetch)
@@ -5835,7 +5936,7 @@ developed as part of the NetSurf project.")
"libnspsl-" version "-src.tar.gz"))
(sha256
(base32
- "02q28n5i6fwqcz1nn167rb71k1q95mx38mfah6zi1lvqrc2q5ifk"))))
+ "105cjkb622wz11z26il4j1n4ydyrrgv0nglr67aawpam5z1wx11n"))))
(build-system gnu-build-system)
(native-inputs
(list netsurf-buildsystem))
@@ -5850,7 +5951,7 @@ Public Suffix List. It is developed as part of the NetSurf project.")
(define-public nsgenbind
(package
(name "nsgenbind")
- (version "0.8")
+ (version "0.9")
(source
(origin
(method url-fetch)
@@ -5858,7 +5959,7 @@ Public Suffix List. It is developed as part of the NetSurf project.")
"nsgenbind-" version "-src.tar.gz"))
(sha256
(base32
- "1cqwgwca49jvmijwiyaab2bwxicgxdrnlpinf8kp3nha02nm73ad"))))
+ "0p9q9ffn9hf1qrphz2qxq2xvyysn5kg2dbl8cbnkwb5wdkvf0b13"))))
(build-system gnu-build-system)
(native-inputs
(list netsurf-buildsystem bison flex))
@@ -5876,7 +5977,7 @@ w3c webidl files and a binding configuration file.")
(define-public netsurf
(package
(name "netsurf")
- (version "3.10")
+ (version "3.11")
(source
(origin
(method url-fetch)
@@ -5884,7 +5985,7 @@ w3c webidl files and a binding configuration file.")
"releases/source/netsurf-" version "-src.tar.gz"))
(sha256
(base32
- "0plra64c5xyiw12yx2q13brxsv8apmany97zqa2lcqckw4ll8j1n"))
+ "1chw40nx7krpy7m14bajfrcj88h98if8py0k7c2qshpfxxm652n2"))
(patches (search-patches "netsurf-system-utf8proc.patch"
"netsurf-y2038-tests.patch"
"netsurf-longer-test-timeout.patch"
@@ -5935,22 +6036,17 @@ w3c webidl files and a binding configuration file.")
(add-after 'unpack 'remove-timestamps
;; Avoid embedding timestamp for reproducible builds
(lambda _
- (substitute* "utils/git-testament.pl"
+ (substitute* "tools/git-testament.pl"
(("WT_COMPILEDATE ..$compiledate")
"WT_COMPILEDATE \\\""))))
(add-after 'build 'adjust-welcome
(lambda _
(substitute* "frontends/gtk/res/welcome.html"
- ;; Close some XHTML tags.
+ ;; Close some XHTML tags.
(("<(img|input)([^>]*)>" _ tag contents)
(string-append "<" tag contents " />"))
;; Increase freedom.
- ((" open source") ", free software")
- ;; Prefer a more privacy-respecting default search engine.
- (("www.google.co.uk") "www.duckduckgo.com/html")
- (("Google Search") "DuckDuckGo Search")
- (("name=\"btnG\"") ""))
- ;; Remove default links so it doesn't seem we're endorsing them.
+ ((" open source") ", free software"))
(with-atomic-file-replacement "frontends/gtk/res/welcome.html"
(lambda (in out)
;; Leave the DOCTYPE header as is.
@@ -5965,8 +6061,23 @@ w3c webidl files and a binding configuration file.")
;; We'd like to use sxml-match here, but it can't
;; match against generic tag symbols...
(match sxml
+ ;; Remove default links so it doesn't seem we're
+ ;; endorsing them.
(`(div (@ (class "links")) . ,rest)
'())
+ ;; Prefer a more privacy-respecting default search
+ ;; engine.
+ (`(form . ,rest)
+ `(form (@ (action "https://lite.duckduckgo.com/lite/")
+ (method "post"))
+ (div (@ (class "websearch"))
+ (input (@ (type "text")
+ (size "42")
+ (name "q")
+ (autocomplete "off")
+ (value "")))
+ (input (@ (type "submit")
+ (value "DuckDuckGo Search"))))))
(`(ENTITY ,ent)
`(*ENTITY* ,ent))
((x ...)
@@ -6489,7 +6600,7 @@ functions of Tidy.")
;; Make sure 'hiawatha' finds 'mbedtls'.
(let* ((out (assoc-ref outputs "out"))
(sbin (string-append out "/sbin"))
- (mbed (assoc-ref inputs "mbedtls-apache")))
+ (mbed (assoc-ref inputs "mbedtls")))
(wrap-program (string-append sbin "/hiawatha")
`("PATH" ":" prefix (,mbed)))))))))
(inputs
@@ -6621,6 +6732,28 @@ Depending on your architecture, it only requires about 40 bytes of data per
message stream (in a web server that is per connection).")
(license license:expat))))
+(define-public llhttp
+ (package
+ (name "llhttp")
+ (version "9.1.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nodejs/llhttp")
+ (commit (string-append "release/v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nkv64c5fs8x6n5f9f6g28w5hvg776p55cwa0f82ni548nx279s1"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f)) ;FIXME: tests depend on node-mocha
+ (home-page "https://github.com/nodejs/llhttp")
+ (synopsis "Port of http_parser to llparse")
+ (description "@code{llparse} is a port of @code{http_parser} to
+@code{llparse} which aims making it more maintainable, verifiable and
+efficient where possible.")
+ (license license:expat)))
+
(define-public python-httpretty
(package
(name "python-httpretty")
@@ -8137,10 +8270,43 @@ compressed JSON header blocks.
(("print \\(ver >= '3\\.8'\\)")
"print (tuple(map(int, ver.split('.'))) >= (3,8))")))))))))))
+(define-public nghttp3
+ (package
+ (name "nghttp3")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ngtcp2/nghttp3/"
+ "releases/download/v" version "/"
+ "nghttp3-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xfa3nbpv3d514ssjpxvizqmss8z330w9p0bp045w4qsyr1vkj8c"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list pkg-config))
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "--enable-lib-only")))
+ (home-page "https://nghttp2.org/nghttp3/")
+ (synopsis "HTTP/3 protocol library")
+ (description
+ "nghttp3 is an implementation of RFC 9114 HTTP/3 mapping over QUIC and
+RFC 9204 QPACK in C. It does not depend on any particular QUIC transport
+implementation.
+
+It implements extensions specified in RFC 9218 and RFC 9220. It supports
+SETTINGS_H3_DATAGRAM from RFC 9297.
+
+It does not support server push.")
+ (license license:expat)))
+
(define-public hpcguix-web
(package
(name "hpcguix-web")
- (version "0.4.0")
+ (version "0.4.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -8149,7 +8315,7 @@ compressed JSON header blocks.
(file-name (git-file-name name version))
(sha256
(base32
- "19l9gvp2ngn7lc3jynrc16f3il2bgkhq1m8zfaqwxk9vwxiivwrn"))))
+ "13a4cwqdhpr7gc1z4cxs36qa50mzcdwwlj9qqzv818sx9d7r6vsw"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -8171,13 +8337,14 @@ compressed JSON header blocks.
(guile (assoc-ref inputs "guile"))
(gcrypt (assoc-ref inputs "guile-gcrypt"))
(git (assoc-ref inputs "guile-git"))
+ (gnutls (assoc-ref inputs "guile-gnutls"))
(bs (assoc-ref inputs "guile-bytestructures"))
(json (assoc-ref inputs "guile-json"))
(zlib (assoc-ref inputs "guile-zlib"))
(syntax (assoc-ref inputs "guile-syntax-highlight"))
(guile-cm (assoc-ref inputs
"guile-commonmark"))
- (deps (list guile gcrypt git bs zlib guile-cm
+ (deps (list guile gcrypt git gnutls bs zlib guile-cm
syntax guix json))
(effective
(read-line
@@ -8209,6 +8376,7 @@ compressed JSON header blocks.
guile-commonmark
guile-json-4
guile-syntax-highlight
+ guile-gnutls ;used to connect to https://disarchive.guix.gnu.org
bash-minimal))
(home-page "https://github.com/UMCUGenetics/hpcguix-web")
(synopsis "Web interface for cluster deployments of Guix")
@@ -8578,7 +8746,7 @@ solution for any project's interface needs:
(define-public gmid
(package
(name "gmid")
- (version "1.8.6")
+ (version "2.0.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -8586,7 +8754,7 @@ solution for any project's interface needs:
version "/gmid-" version ".tar.gz"))
(sha256
(base32
- "1j0bgnixffz2lv5xgp5c88hl146c1vyk1988gyd70mhgyl9700jy"))))
+ "1riihzgshfk6907r4g69lrlvabiznwi5d7njk7y6km0695lf62g0"))))
(build-system gnu-build-system)
(arguments
(list #:test-target "regress"