summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm79
1 files changed, 58 insertions, 21 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 50a837f51b..916c98dddb 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016, 2017, 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018, 2020 Marius Bakke <mbakke@fastmail.com>
@@ -30,7 +30,7 @@
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019, 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
@@ -43,9 +43,9 @@
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018, 2019, 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
-;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
+;;; Copyright © 2020, 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;; Copyright © 2020, 2021 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;;
;;; This file is part of GNU Guix.
@@ -684,7 +684,7 @@ programming language.")))
(define-public lighttpd
(package
(name "lighttpd")
- (version "1.4.57")
+ (version "1.4.59")
(source (origin
(method url-fetch)
(uri (string-append "https://download.lighttpd.net/lighttpd/"
@@ -692,7 +692,7 @@ programming language.")))
"lighttpd-" version ".tar.xz"))
(sha256
(base32
- "0zr1ssagirv5l4r2ii1k9v366a4vwylwbq74nb5pwby1i4drdjjj"))))
+ "1mc421yrbnq3k6yrc708svp0fgcamrn5a0p2nvnhivysffr3v5gv"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -1478,7 +1478,7 @@ used to validate and fix HTML data.")
(define-public esbuild
(package
(name "esbuild")
- (version "0.8.26")
+ (version "0.8.37")
(source
(origin
(method git-fetch)
@@ -1487,7 +1487,7 @@ used to validate and fix HTML data.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0zw68mgmmicbkvx7s22knvm8nng5qn41b1chn35prhkla3kx1jn1"))
+ (base32 "0c98w2y4y9jaj2wv0334xwdbsvsi5hfh9jdkqr7ffz8lxhmh610f"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3867,8 +3867,7 @@ exists it is used instead.")
(propagated-inputs
`(("perl-io-socket-ssl" ,perl-io-socket-ssl)
("perl-libwww" ,perl-libwww)
- ;; Users should instead make sure SSL_ca_path is set properly.
- ;; ("perl-mozilla-ca" ,perl-mozilla-ca)
+ ("perl-mozilla-ca" ,perl-mozilla-ca)
("perl-net-http" ,perl-net-http)))
(home-page "https://metacpan.org/release/LWP-Protocol-https")
(synopsis "HTTPS support for LWP::UserAgent")
@@ -3996,7 +3995,7 @@ is limited to http and https.")
(define-public perl-net-http
(package
(name "perl-net-http")
- (version "6.19")
+ (version "6.20")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4004,7 +4003,7 @@ is limited to http and https.")
"Net-HTTP-" version ".tar.gz"))
(sha256
(base32
- "1i1gbcwdzx74whn5vn6xbr2cp7frldfz2rfrcjp2qljr770nxdsj"))))
+ "07lzfycza7qqxli18xgsnqwiwxapl0b64z33wfw62aai4hm7nllj"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-io-socket-ssl" ,perl-io-socket-ssl)
@@ -4634,20 +4633,20 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(package-with-python2 python-feedparser))
(define-public guix-data-service
- (let ((commit "c596a1c6a90bb2fe07da5339b8dc832b81d94194")
- (revision "21"))
+ (let ((commit "b7ba8d0c2ca3aca9ba5b5f9f27b9778ee949d20e")
+ (revision "25"))
(package
(name "guix-data-service")
(version (string-append "0.0.1-" revision "." (string-take commit 7)))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://git.savannah.gnu.org/git/guix/data-service.git")
+ (url "https://git.savannah.gnu.org/git/guix/data-service.git/")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "09gn2imhh3aqkzray0xgkz7slriy567inh5lpkxm74bgmx862g3g"))))
+ "0brv64bsqysl7dncz067blwvmqrlx99c2kwrgpz6k0nqv8nzsa28"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
@@ -4729,7 +4728,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
through a web interface. It supports listening to the guix-commits mailing
list to find out about new revisions, then loads the data from these in to a
PostgreSQL database.")
- (home-page "http://data.guix.gnu.org/")
+ (home-page "https://data.guix.gnu.org/")
(license license:agpl3+))))
(define-public gumbo-parser
@@ -5127,6 +5126,7 @@ NetSurf project.")
("perl-xml-feed" ,perl-xml-feed)
("perl-xml-sax" ,perl-xml-sax)
("perl-xml-twig" ,perl-xml-twig)
+ ("perl-yaml-tiny" ,perl-yaml-tiny)
("po4a" ,po4a)))
(propagated-inputs
`(("perl-cgi-formbuilder" ,perl-cgi-formbuilder)
@@ -6512,7 +6512,7 @@ collection creation and deletion, and locking operations.")
(arguments
`(#:cargo-inputs
(("rust-ansi-parser" ,rust-ansi-parser-0.6)
- ("rust-dirs" ,rust-dirs-2.0)
+ ("rust-dirs" ,rust-dirs-2)
("rust-gdk" ,rust-gdk-0.13)
("rust-gtk" ,rust-gtk-0.8)
("rust-linkify" ,rust-linkify-0.4)
@@ -7638,15 +7638,14 @@ HTTrack is fully configurable, and has an integrated help system.")
(define-public buku
(package
(name "buku")
- (version "4.4")
+ (version "4.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "buku" version))
(file-name (git-file-name name version))
(sha256
- (base32
- "1g1xhdskfn72xaraqzz2v8dl2iza7bzfpn17z2wdrzkq3ih7yvgg"))))
+ (base32 "1bk3h2ya34a5livyf6p7kawh50ikbix5szsq2rkb8cp5bwrzsj5i"))))
(build-system python-build-system)
(arguments
`(#:tests? #f)) ;FIXME: many tests need network access
@@ -8016,3 +8015,41 @@ handling library written in C89 (\"ANSI C\"). uriparser is fast and supports
Unicode.")
(home-page "https://uriparser.github.io/")
(license license:bsd-3))))
+
+(define-public quark
+ ;; No releases yet
+ (let ((revision "0")
+ (commit "c6a9055e5a30be570e30da8d216c39662c3a3f99"))
+ (package
+ (name "quark")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.suckless.org/quark/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1znvnr30xi5vgd6n3wvgv9pwj992zpzzjk0fmq28ydf1l6kqvkm7"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (home-page "https://tools.suckless.org/quark/")
+ (synopsis "Small and simple HTTP GET/HEAD-only web server for static
+content")
+ (description "Quark is an extremely small and simple HTTP GET/HEAD only
+web server for static content. TLS is not natively supported and should be
+provided by a TLS reverse proxy (e.g. tlstunnel, hitch or stunnel).")
+ (license license:isc)
+
+ ;; XXX: Ignore this CVE to work around a name clash with the unrelated
+ ;; "cpe:2.3:a:comelz:quark" package. The proper fix is for (guix cve)
+ ;; to account for "vendor names".
+ (properties '((lint-hidden-cve . ("CVE-2019-15520")))))))