summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm135
1 files changed, 133 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ac65a85365..6c9316a401 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -76,9 +76,11 @@
#:use-module (gnu packages java)
#:use-module (gnu packages javascript)
#:use-module (gnu packages image)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libunistring)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages markup)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages base)
#:use-module (gnu packages perl)
@@ -92,7 +94,8 @@
#:use-module (gnu packages texinfo)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
- #:use-module (gnu packages statistics))
+ #:use-module (gnu packages statistics)
+ #:use-module (gnu packages version-control))
(define-public httpd
(package
@@ -104,7 +107,8 @@
version ".tar.bz2"))
(sha256
(base32
- "0fn1778mxhf78np2d8qlycg1c2ak18rxax41plahasca4clc3z3i"))))
+ "0fn1778mxhf78np2d8qlycg1c2ak18rxax41plahasca4clc3z3i"))
+ (patches (search-patches "httpd-CVE-2017-9798.patch"))))
(build-system gnu-build-system)
(native-inputs `(("pcre" ,pcre "bin"))) ;for 'pcre-config'
(inputs `(("apr" ,apr)
@@ -162,6 +166,7 @@ and its related documentation.")
(let ((flags
(list (string-append "--prefix=" (assoc-ref outputs "out"))
"--with-http_ssl_module"
+ "--with-http_v2_module"
"--with-pcre-jit"
"--with-debug"
;; Even when not cross-building, we pass the
@@ -1912,6 +1917,33 @@ string generation and manipulation, and processing and preparing HTTP
headers.")
(license l:perl-license)))
+(define-public perl-cgi-session
+ (package
+ (name "perl-cgi-session")
+ (version "4.48")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MA/MARKSTOS/CGI-Session-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1xsl2pz1jrh127pq0b01yffnj4mnp9nvkp88h5mndrscq9hn8xa6"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (inputs `(("perl-cgi" ,perl-cgi)))
+ (home-page
+ "http://search.cpan.org/dist/CGI-Session")
+ (synopsis
+ "Persistent session data in CGI applications")
+ (description
+ "@code{CGI::Session} provides modular session management system across
+HTTP requests.")
+ (license l:perl-license)))
+
(define-public perl-cgi-simple
(package
(name "perl-cgi-simple")
@@ -2184,6 +2216,37 @@ composed of HTML::Element style components.")
<form> ... </form> instance.")
(license l:perl-license)))
+(define-public perl-html-scrubber
+ (package
+ (name "perl-html-scrubber")
+ (version "0.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/N/NI/NIGELM/HTML-Scrubber-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1m1f8gm2jry42zxja05dxp2ck7y66m7i8vc38nj6hccnwlby6cvi"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-test-cpan-meta" ,perl-test-cpan-meta)
+ ("perl-test-eol" ,perl-test-eol)
+ ("perl-test-memory-cycle" ,perl-test-memory-cycle)
+ ("perl-test-notabs" ,perl-test-notabs)))
+ (inputs
+ `(("perl-html-parser" ,perl-html-parser)))
+ (home-page
+ "http://search.cpan.org/dist/HTML-Scrubber")
+ (synopsis
+ "Perl extension for scrubbing/sanitizing html")
+ (description
+ "@code{HTML::Scrubber} Perl extension for scrubbing/sanitizing HTML.")
+ (license l:perl-license)))
+
(define-public perl-html-lint
(package
(name "perl-html-lint")
@@ -4010,6 +4073,74 @@ parse both valid and invalid web content. It is developed as part of the
NetSurf project.")
(license l:expat)))
+(define-public ikiwiki
+ (package
+ (name "ikiwiki")
+ (version "3.20170111")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://snapshot.debian.org/archive/debian/"
+ "20170111T215449Z/pool/main/i/ikiwiki/ikiwiki_"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "00d7yzv426fvqbhvzyafddv7fa6b4j2647b0wi371wd5yjj9j3sz"))))
+ (build-system perl-build-system)
+ (arguments
+ `(;; Image tests fail
+ ;;
+ ;; Test Summary Report
+ ;; -------------------
+ ;; t/img.t (Wstat: 2304 Tests: 62 Failed: 9)
+ ;; Failed tests: 21, 27-28, 30-35
+ ;; Non-zero exit status: 9
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-programs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/"))
+ (path (getenv "PERL5LIB")))
+ (for-each (lambda (file)
+ (wrap-program file
+ `("PERL5LIB" ":" prefix (,path))))
+ (find-files bin))
+ #t))))))
+ (native-inputs
+ `(("which" ,which)
+ ("perl-html-tagset" ,perl-html-tagset)
+ ("perl-timedate" ,perl-timedate)
+ ("perl-xml-sax" ,perl-xml-sax)
+ ("perl-xml-simple" ,perl-xml-simple)
+ ("gettext" ,gettext-minimal)
+ ("subversion" ,subversion)
+ ("git" ,git)
+ ("bazaar" ,bazaar)
+ ("cvs" ,cvs)
+ ("mercurial" ,mercurial)))
+ (inputs
+ `(("python" ,python-wrapper)
+ ("perl-cgi-session" ,perl-cgi-session)
+ ("perl-cgi-simple" ,perl-cgi-simple)
+ ("perl-json" ,perl-json)
+ ("perl-image-magick" ,perl-image-magick)
+ ("perl-uri" ,perl-uri)
+ ("perl-html-parser" ,perl-html-parser)
+ ("perl-uri" ,perl-uri)
+ ("perl-text-markdown-discount" ,perl-text-markdown-discount)
+ ("perl-html-scrubber" ,perl-html-scrubber)
+ ("perl-html-template" ,perl-html-template)
+ ("perl-yaml-libyaml" ,perl-yaml-libyaml)))
+ (home-page "https://ikiwiki.info/")
+ (synopsis "Wiki compiler, capable of generating HTML")
+ (description
+ "Ikiwiki is a wiki compiler, capable of generating a static set of web
+pages, but also incorporating dynamic features like a web based editor and
+commenting.")
+ (license l:gpl2+)))
+
(define-public libwapcaplet
(package
(name "libwapcaplet")