summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm160
1 files changed, 74 insertions, 86 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 070b8f705d..1749ad0b71 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
+;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
;;; Copyright © 2016, 2017, 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
@@ -749,33 +749,34 @@ current version of any major web browser.")
(name "rapidjson")
(version "1.1.0")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Tencent/rapidjson.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1jixgb8w97l9gdh3inihz7avz7i770gy2j2irvvlyrq3wi41f5ab"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove code using the problematic JSON license (see
- ;; <https://www.gnu.org/licenses/license-list.html#JSON>).
- (delete-file-recursively "bin/jsonchecker")
- #t))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Tencent/rapidjson.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jixgb8w97l9gdh3inihz7avz7i770gy2j2irvvlyrq3wi41f5ab"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove code using the problematic JSON license (see
+ ;; <https://www.gnu.org/licenses/license-list.html#JSON>).
+ (delete-file-recursively "bin/jsonchecker")
+ #t))))
(build-system cmake-build-system)
(arguments
- `(,@(if (string-prefix? "aarch64" (or (%current-target-system)
- (%current-system)))
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-aarch-march-detection
- (lambda _
- (substitute* (find-files "." "^CMakeLists\\.txt$")
- (("native") "armv8-a"))
- #t))))
- '())))
+ (if (string-prefix? "aarch64" (or (%current-target-system)
+ (%current-system)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-aarch-march-detection
+ (lambda _
+ (substitute* (find-files "." "^CMakeLists\\.txt$")
+ (("native") "armv8-a"))
+ #t))))
+ ;; Disable CPU optimization for reproducibility.
+ '(#:configure-flags '("-DRAPIDJSON_ENABLE_INSTRUMENTATION_OPT=OFF"))))
(home-page "https://github.com/Tencent/rapidjson")
(synopsis "JSON parser/generator for C++ with both SAX/DOM style API")
(description
@@ -1337,25 +1338,24 @@ language known as SASS.")
(define-public perl-apache-logformat-compiler
(package
(name "perl-apache-logformat-compiler")
- (version "0.33")
+ (version "0.35")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/K/KA/KAZEBURO/"
"Apache-LogFormat-Compiler-" version ".tar.gz"))
(sha256
- (base32
- "17blk3zhp05azgypn25ydxf3d7fyfgr9bxyiv7xkchhqma96vwqv"))))
+ (base32 "06i70ydxk2wa2rcqn16842kra2qz3jwk0vk1abq8lah4180c0m0n"))))
(build-system perl-build-system)
(native-inputs
`(("perl-http-message" ,perl-http-message)
- ("perl-module-build" ,perl-module-build)
+ ("perl-module-build-tiny" ,perl-module-build-tiny)
("perl-test-mocktime" ,perl-test-mocktime)
("perl-try-tiny" ,perl-try-tiny)
("perl-uri" ,perl-uri)))
(propagated-inputs
`(("perl-posix-strftime-compiler" ,perl-posix-strftime-compiler)))
- (arguments `(#:tests? #f)) ;TODO: Timezone test failures
+ (arguments `(#:tests? #f)) ; TODO: Timezone test failures
(home-page "https://metacpan.org/release/Apache-LogFormat-Compiler")
(synopsis "Compile a log format string to perl-code")
(description "This module provides methods to compile a log format string
@@ -1420,14 +1420,14 @@ action, which will forward to the first available view.")
(define-public perl-catalyst-action-rest
(package
(name "perl-catalyst-action-rest")
- (version "1.20")
+ (version "1.21")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/J/JJ/JJNAPIORK/"
"Catalyst-Action-REST-" version ".tar.gz"))
(sha256
(base32
- "1mpa64p61f3dp24xnhdraswch4sqj5vyv1iivcvvh5h0xi0haiy0"))))
+ "086bykggzalbjfk0islac4b48g9s2ypj7y81d6ns1lq0aax1py6c"))))
(build-system perl-build-system)
(native-inputs
`(("perl-test-requires" ,perl-test-requires)
@@ -1780,15 +1780,14 @@ formats.")
(define-public perl-catalyst-plugin-session
(package
(name "perl-catalyst-plugin-session")
- (version "0.40")
+ (version "0.41")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/J/JJ/JJNAPIORK/"
"Catalyst-Plugin-Session-" version ".tar.gz"))
(sha256
- (base32
- "171vi9xcl775scjaw4fcfdmqvz0rb1nr0xxg2gb3ng6bjzpslhgv"))))
+ (base32 "0a451997zc2vjx7rvndgx1ldbrpic8sfbddyvncynh0zr8bhlqc5"))))
(build-system perl-build-system)
(native-inputs
`(("perl-module-install" ,perl-module-install)
@@ -2267,15 +2266,14 @@ HTTP requests.")
(define-public perl-cgi-simple
(package
(name "perl-cgi-simple")
- (version "1.15")
+ (version "1.21")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/M/MA/MANWAR/"
"CGI-Simple-" version ".tar.gz"))
(sha256
- (base32
- "013dcy9k4sj9alkksk5aqz65ryxw0rxgg71c7w666y941gd8n46q"))))
+ (base32 "1wzc2igs4khmj7zfahvs87c24p9ks8hnqhhsyviyiix53xx2y6sg"))))
(build-system perl-build-system)
(native-inputs
`(("perl-io-stringy" ,perl-io-stringy) ; for IO::Scalar
@@ -2437,15 +2435,14 @@ which can be used to parse directory listings.")
(define-public perl-finance-quote
(package
(name "perl-finance-quote")
- (version "1.38")
+ (version "1.47")
(source
(origin
(method url-fetch)
(uri (string-append "https://cpan.metacpan.org/authors/id/E/EC/ECOCODE/"
"Finance-Quote-" version ".tar.gz"))
(sha256
- (base32
- "0zhqb27y4vdxn476s2kwm9zl2f970yjcyyybnjm9b406krr2fm59"))
+ (base32 "0gzbq85738f299jaw4nj3ljnka380j2y6yspmyl71rgfypqjvbr7"))
(patches (search-patches
"perl-finance-quote-unuse-mozilla-ca.patch"))))
(build-system perl-build-system)
@@ -2573,15 +2570,14 @@ composed of HTML::Element style components.")
(define-public perl-html-lint
(package
(name "perl-html-lint")
- (version "2.26")
+ (version "2.32")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/P/PE/PETDANCE/"
"HTML-Lint-" version ".tar.gz"))
(sha256
- (base32
- "02vi1s4sw3hjnndxd6s91cp54iw5pg8n5kl9v0109dfxzn1n9bnl"))))
+ (base32 "0lk02xpfxcg7ij4dvpsa4wjlzhmiizj0jfr3rwmdpbj69nvc93br"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-html-parser" ,perl-html-parser)
@@ -3085,15 +3081,15 @@ select or poll.")
(define-public perl-libwww
(package
(name "perl-libwww")
- (version "6.35")
+ (version "6.37")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://cpan/authors/id/E/ET/ETHER/libwww-perl-"
+ "mirror://cpan/authors/id/O/OA/OALDERS/libwww-perl-"
version ".tar.gz"))
(sha256
(base32
- "0lsrr8r61b67f9wrynkhdhldw5yic4d7cd78zi52q59jgf6mg8nx"))))
+ "04a24cx9gs070rvlwf5kanz03y7nnq9k2nmpr01plnm059iprvf6"))))
(build-system perl-build-system)
(native-inputs
`(("perl-test-fatal" ,perl-test-fatal)
@@ -3406,16 +3402,15 @@ already set.")
(define-public perl-plack-middleware-methodoverride
(package
(name "perl-plack-middleware-methodoverride")
- (version "0.11")
+ (version "0.20")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/D/DW/DWHEELER/"
+ (uri (string-append "mirror://cpan/authors/id/M/MI/MIYAGAWA/"
"Plack-Middleware-MethodOverride-"
version ".tar.gz"))
(sha256
- (base32
- "1hb8dx7i4vs74n0p737wrvpdnnw6argxrjpr6kj6432zabp8325z"))))
+ (base32 "1wdmmav3rbhv49zpw311zrxxqmg1fz3f3q9src0ypgs8zcp5myyv"))))
(build-system perl-build-system)
(native-inputs
`(("perl-module-build" ,perl-module-build)))
@@ -3432,7 +3427,7 @@ can say what method it actually meant.")
(define-public perl-plack-middleware-removeredundantbody
(package
(name "perl-plack-middleware-removeredundantbody")
- (version "0.05")
+ (version "0.07")
(source
(origin
(method url-fetch)
@@ -3440,8 +3435,7 @@ can say what method it actually meant.")
"Plack-Middleware-RemoveRedundantBody-"
version ".tar.gz"))
(sha256
- (base32
- "1n3wm0zi8dnk54jx937asl951lslj3jvw0fry4jpzsibg4f6wrx0"))))
+ (base32 "1hz3kgb5vw4r02gfk9i911f5ykvz55lrsx45bdcllk2bszal3f34"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-plack" ,perl-plack)))
@@ -3455,7 +3449,7 @@ required.")
(define-public perl-plack-middleware-reverseproxy
(package
(name "perl-plack-middleware-reverseproxy")
- (version "0.15")
+ (version "0.16")
(source
(origin
(method url-fetch)
@@ -3463,8 +3457,7 @@ required.")
"Plack-Middleware-ReverseProxy-"
version ".tar.gz"))
(sha256
- (base32
- "1zmsccdy6wr5hxzj07r1nsmaymyibk87p95z0wzknjw10lwmqs9f"))))
+ (base32 "0a512n62pnk5ayj3zdzyj50iy1qi8nwh6ygks2h7nrh7gp9k2jc7"))))
(build-system perl-build-system)
(native-inputs
`(("perl-module-install" ,perl-module-install)))
@@ -3480,15 +3473,14 @@ and stop fake requests using 'enable_if' directive in your app.psgi.")
(define-public perl-plack-test-externalserver
(package
(name "perl-plack-test-externalserver")
- (version "0.01")
+ (version "0.02")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/F/FL/FLORA/"
"Plack-Test-ExternalServer-" version ".tar.gz"))
(sha256
- (base32
- "1dbg1p3rgvvbkkpvca5jlc2mzx8iqyiybk88al93pvbca65h1g7h"))))
+ (base32 "1l1yj1l25679x7cbpd27ii7s1f1ajpkspif9xqnl21hczrbmrbsv"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-plack" ,perl-plack)))
@@ -3502,15 +3494,14 @@ either mocked HTTP or a locally spawned server.")
(define-public perl-test-tcp
(package
(name "perl-test-tcp")
- (version "2.06")
+ (version "2.19")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/T/TO/TOKUHIROM/"
"Test-TCP-" version ".tar.gz"))
(sha256
- (base32
- "0acjwm21y2an4f3fasci9qa0isakh9cgp74fk0bzcdi506xmcjbi"))))
+ (base32 "14ahzklq3xgmwj58p9vdcfgpggrmh3nigq5mzqk4wakbb6fjs0fx"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-test-sharedfork" ,perl-test-sharedfork)))
@@ -3523,15 +3514,14 @@ either mocked HTTP or a locally spawned server.")
(define-public perl-test-www-mechanize
(package
(name "perl-test-www-mechanize")
- (version "1.50")
+ (version "1.52")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/P/PE/PETDANCE/"
"Test-WWW-Mechanize-" version ".tar.gz"))
(sha256
- (base32
- "097pl87vdbxbb56vawzvs6ikrlb8nz3dx223kjjbdn3jlli3jjhg"))))
+ (base32 "1jsywlbxhqw39ij7s8vmgff5vys58vlfaq27072awacnxc65aal4"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-carp-assert-more" ,perl-carp-assert-more)
@@ -3706,14 +3696,14 @@ methods for WebSocket URIs as it does for HTTP URIs.")
(define-public perl-uri-template
(package
(name "perl-uri-template")
- (version "0.23")
+ (version "0.24")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/B/BR/BRICAS/URI-Template-"
version ".tar.gz"))
(sha256
(base32
- "0nnijyv4n5qfg7l94j7fmvqy9cbq3gl9sz9anmgsiprmkmpk419j"))))
+ "1phibcmam2hklrddzj79l43va1gcqpyszbw21ynxq53ynmhjvbk8"))))
(build-system perl-build-system)
(inputs
`(("perl-uri" ,perl-uri)))
@@ -3766,15 +3756,14 @@ library.")
(define-public perl-www-mechanize
(package
(name "perl-www-mechanize")
- (version "1.89")
+ (version "1.91")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/O/OA/OALDERS/"
"WWW-Mechanize-" version ".tar.gz"))
(sha256
- (base32
- "1mxx362vqiniw8vi6k3j7v9b1s7012irhfcblcz1p6jz9cjqi7mh"))))
+ (base32 "0cb14m1vhaf0mgn2fqwi5hm72xhfi77hpq2g57swgy0w83x7m27b"))))
(build-system perl-build-system)
(native-inputs ;only for tests
`(("perl-cgi" ,perl-cgi)
@@ -4812,13 +4801,13 @@ deployments.")
(package
(name "varnish")
(home-page "https://varnish-cache.org/")
- (version "6.1.1")
+ (version "6.2.0")
(source (origin
(method url-fetch)
(uri (string-append home-page "_downloads/varnish-" version ".tgz"))
(sha256
(base32
- "0gf9hzzrr1lndbbqi8cwlfasi7l517cy3nbgna88i78lm247rvp0"))))
+ "0lwfk2gq99c653h5f51fs3j37r0gh2pf0p4w5z986nm2mi9z6yn3"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib")
@@ -4826,10 +4815,6 @@ deployments.")
(string-append "PTHREAD_CC="
(assoc-ref %build-inputs "gcc")
"/bin/gcc")
- ;; XXX: Disable PCRE-JIT to work around a segmentation
- ;; fault when using jemalloc 5.x:
- ;; <https://github.com/varnishcache/varnish-cache/issues/2817>
- "--disable-pcre-jit"
"--localstatedir=/var")
#:phases
(modify-phases %standard-phases
@@ -4841,6 +4826,8 @@ deployments.")
(("/bin/sh") (which "sh")))
(substitute* "bin/varnishd/mgt/mgt_shmem.c"
(("rm -rf") (string-append (which "rm") " -rf")))
+ (substitute* "bin/varnishtest/vtc_main.c"
+ (("/bin/rm") (which "rm")))
#t))
(add-before 'install 'patch-Makefile
(lambda _
@@ -6200,24 +6187,25 @@ in Perl but is not nearly as capable as @code{HTML::Tidy}.")
(define-public geomyidae
(package
(name "geomyidae")
- (version "0.31")
+ (version "0.34")
(source
(origin
- (method url-fetch)
- (uri (string-append "http://git.r-36.net/geomyidae/snapshot/"
- "geomyidae-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://r-36.net/geomyidae")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1ih7220c6mgq4r7blm4kx3pxbl53sph58lqgwci6cmi3c0sq5c3x"))))
+ (base32 "02afgrk36wkdkflyqr2xgh49v9zq6ma454jshk7igvhpxfb5l3ks"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list "CC=gcc"
(string-append "PREFIX="
(assoc-ref %outputs "out")))
- #:tests? #f ;no tests
+ #:tests? #f ; no tests
#:phases (modify-phases %standard-phases
(delete 'configure))))
- (home-page "http://git.r-36.net/geomyidae")
+ (home-page "http://r-36.net/scm/geomyidae/file/README.html")
(synopsis "Small Gopher server")
(description
"Geomyidae is a server for distributed hypertext protocol Gopher. Its