summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm36
1 files changed, 19 insertions, 17 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b2e1e66546..3ddecb15c4 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2017, 2018, 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2017, 2018, 2020, 2021, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2017, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -54,6 +54,7 @@
;;; Copyright © 2021 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4621,20 +4622,24 @@ their web site.")
(method url-fetch)
(uri (pypi-uri "feedparser" version ".tar.gz"))
(sha256
- (base32
- "0qcnkyjjfj5gg5rhd1j4zzlqx5h34bma18zwgj68q95b0l543q2w"))))
+ (base32 "0qcnkyjjfj5gg5rhd1j4zzlqx5h34bma18zwgj68q95b0l543q2w"))))
(build-system python-build-system)
(propagated-inputs
(list python-sgmllib3k))
(arguments
- '(#:tests? #f))
- (home-page
- "https://github.com/kurtmckee/feedparser")
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "tests/runtests.py")))))))
+ (home-page "https://github.com/kurtmckee/feedparser")
(synopsis "Parse feeds in Python")
(description
"Universal feed parser which handles RSS 0.9x, RSS 1.0, RSS 2.0,
CDF, Atom 0.3, and Atom 1.0 feeds.")
- (license (list license:bsd-2 ; source code
+ (license (list license:bsd-2 ; source code
license:freebsd-doc)))) ; documentation
(define-public python2-feedparser
@@ -5854,17 +5859,16 @@ deployments.")
(string-append "CC=" ,(cc-for-target))
;; Use absolute path of GCC so it's found at runtime.
(string-append "PTHREAD_CC="
- (assoc-ref %build-inputs "gcc")
- "/bin/gcc")
+ (search-input-file %build-inputs
+ "/bin/gcc"))
"--localstatedir=/var")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'use-absolute-file-names
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((bash (assoc-ref inputs "bash-minimal"))
- (sh (string-append bash "/bin/sh"))
- (coreutils (assoc-ref inputs "coreutils"))
- (rm (string-append coreutils "/bin/rm")))
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (let* ((inpts (or native-inputs inputs))
+ (sh (search-input-file inpts "/bin/sh"))
+ (rm (search-input-file inpts "/bin/rm")))
(substitute* '("bin/varnishtest/vtc_varnish.c"
"bin/varnishtest/vtc_process.c"
"bin/varnishtest/vtc_haproxy.c"
@@ -5894,9 +5898,7 @@ deployments.")
;; Make sure 'crti.o' et.al is found.
`("LIBRARY_PATH" ":" prefix (,LIBRARY_PATH)))))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("python-sphinx" ,python-sphinx)
- ("rst2man" ,python-docutils)))
+ (list pkg-config python-sphinx python-docutils))
(inputs
(list bash-minimal
coreutils