summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b674019b8f..473fe2ff97 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -196,7 +196,7 @@ and its related documentation.")
(define-public mod-wsgi
(package
(name "mod-wsgi")
- (version "4.5.22")
+ (version "4.7.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -205,7 +205,7 @@ and its related documentation.")
(file-name (git-file-name name version))
(sha256
(base32
- "1q90xw2cbhka5gcd6yc69iir73x4gm7fm75qpkins2ryfl6w1q3f"))))
+ "1savh6h3qds20mwn1nqasmqzcp57pdhfc9v4b4k78d6q28y0r17s"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; TODO: can't figure out if there are tests
@@ -1675,7 +1675,7 @@ minimum to provide high performance operation.")
(package
(name "libsass")
;; When updating, check whether sassc/libsass-3.5 is still needed.
- (version "3.6.3")
+ (version "3.6.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1684,7 +1684,7 @@ minimum to provide high performance operation.")
(file-name (git-file-name name version))
(sha256
(base32
- "1vn0q343d1vxz5q0xb6f9dzjah8z6j0s6x0lwvwdd55xa8z7rsnh"))))
+ "0r8lfqvr3rjhjd8r036zd1wc9q17gyiskppcw9m13jks9an7xp4j"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -4455,8 +4455,8 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(package-with-python2 python-feedparser))
(define-public guix-data-service
- (let ((commit "ab68b0fdb3efe68f1962b7b9698ffc225abfeabb")
- (revision "20"))
+ (let ((commit "c596a1c6a90bb2fe07da5339b8dc832b81d94194")
+ (revision "21"))
(package
(name "guix-data-service")
(version (string-append "0.0.1-" revision "." (string-take commit 7)))
@@ -4468,7 +4468,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(file-name (git-file-name name version))
(sha256
(base32
- "0imbkrm46ykjip81cbf14gc6hqlgi79fnwvsjxbhkd2wq3c1nrjg"))))
+ "09gn2imhh3aqkzray0xgkz7slriy567inh5lpkxm74bgmx862g3g"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
@@ -4531,6 +4531,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
("guile-fibers" ,guile3.0-fibers)
("guile-json" ,guile3.0-json)
("guile-email" ,guile3.0-email)
+ ("guile-prometheus" ,guile-prometheus)
("guile-squee" ,guile3.0-squee)
("ephemeralpg" ,ephemeralpg)
("util-linux" ,util-linux)
@@ -5026,7 +5027,7 @@ written in C. It is developed as part of the NetSurf project.")
(define-public libcyaml
(package
(name "libcyaml")
- (version "1.0.1")
+ (version "1.1.0")
(source
(origin
(method git-fetch)
@@ -5035,7 +5036,7 @@ written in C. It is developed as part of the NetSurf project.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0h5ydyqdl8kzh526np3jsi0pm7ks16nh1hjkdsjcd6pacw7y6i6z"))))
+ (base32 "0428p0rwq71nhh5nzcbapsbrjxa0x5l6h6ns32nxv7j624f0zd93"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags