summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 34b7ee32d0..e632d9c874 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3287,6 +3287,20 @@ applications.")
(base32
"04fwasg400v8dvkcn1fcha1jzdz8lbyxi0679q7flsyrp57b3jrf"))))
(build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; The environment variable CURL_CA_BUNDLE is only respected when
+ ;; running Windows, so we disable the platform checks.
+ ;; This can be removed once the libcurl has been patched.
+ (add-after 'unpack 'allow-CURL_CA_BUNDLE
+ (lambda _
+ (substitute* "R/onload.R"
+ (("if \\(!grepl\\(\"mingw\".*")
+ "if (FALSE)\n"))
+ (substitute* "src/handle.c"
+ (("#ifdef _WIN32") "#if 1"))
+ #t)))))
(inputs
`(("libcurl" ,curl)))
(home-page "https://github.com/jeroenooms/curl")