summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a02ee5a64d..6cfe8fb1e9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -957,9 +957,9 @@ of people.")
; named 'stubout'". The tests can be run by replacing the check phase with
; the command "python setup.py nosetests --verbosity=3".
(native-inputs `(; Required for tests:
- ("python-mox3", python-mox3)
- ("python-nose", python-nose)))
- (propagated-inputs `(("python-numpy", python-numpy)))
+ ("python-mox3" ,python-mox3)
+ ("python-nose" ,python-nose)))
+ (propagated-inputs `(("python-numpy" ,python-numpy)))
(home-page "https://github.com/novnc/websockify")
(synopsis "WebSockets support for any application/server")
(description "Websockify translates WebSockets traffic to normal socket
@@ -986,7 +986,7 @@ directions.")
#:tests? #f)) ; no test target
(native-inputs `(("flex" ,flex)))
(inputs `(("gnutls" ,gnutls)
- ("libcrypt", libgcrypt)))
+ ("libcrypt" ,libgcrypt)))
(home-page "https://www.gedanken.org.uk/software/wwwoffle/")
(synopsis "Caching web proxy optimized for intermittent internet links")
(description "WWWOFFLE is a proxy web server that is especially good for
@@ -4048,14 +4048,14 @@ a pure C99 library.")
(define-public uwsgi
(package
(name "uwsgi")
- (version "2.0.15")
+ (version "2.0.17")
(source (origin
(method url-fetch)
- (uri (string-append "http://projects.unbit.it/downloads/uwsgi-"
+ (uri (string-append "https://projects.unbit.it/downloads/uwsgi-"
version ".tar.gz"))
(sha256
(base32
- "1zvj28wp3c1hacpd4c6ra5ilwvvfq3l8y6gn8i7mnncpddlzjbjp"))))
+ "1wlbaairsmhp6bx5wv282q9pgh6w7w6yrb8vxjznfaxrinsfkhix"))))
(build-system gnu-build-system)
(outputs '("out" "python"))
(arguments
@@ -4968,10 +4968,10 @@ used to start services with both privileged and non-privileged port numbers.")
"0n29wcgw32rhnraj9j21ibhwi0xagmmcskhbaz8ihxly7nx3p9h8"))))
(build-system cmake-build-system)
(outputs '("out"
- "static")) ; 1.0MiB of .a files
+ "static")) ; 1.0MiB of .a files
(arguments
- `(#:tests? #f ; No tests available
- #:configure-flags (list "-DCMAKE_BUILD_TYPE=Release")
+ `(#:tests? #f ; no tests available
+ #:build-type "Release"
#:phases
(modify-phases %standard-phases
(add-after 'install 'move-static-libraries