summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm222
1 files changed, 200 insertions, 22 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5088aa07e0..076b82124d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -25,7 +25,7 @@
;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017, 2019 Christopher Baines <mail@cbaines.net>
-;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2018, 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
@@ -37,6 +37,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
+;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -136,7 +137,8 @@
#:use-module (gnu packages valgrind)
#:use-module (gnu packages version-control)
#:use-module (gnu packages vim)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module ((srfi srfi-1) #:select (delete-duplicates)))
(define-public httpd
(package
@@ -214,14 +216,14 @@ Interface} specification.")
;; ’stable’ and recommends that “in general you deploy the NGINX mainline
;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
;; Consider updating the nginx-documentation package together with this one.
- (version "1.17.4")
+ (version "1.17.5")
(source (origin
(method url-fetch)
(uri (string-append "https://nginx.org/download/nginx-"
version ".tar.gz"))
(sha256
(base32
- "0mg521bxh8pysmy20x599m252ici9w97kk7qy7s0wrv6bqv4p1b2"))))
+ "1hqhziic4csci8xs4q8vbzpmj2qjkhmmx68zza7h5bvmbbhkbvk3"))))
(build-system gnu-build-system)
(inputs `(("openssl" ,openssl)
("pcre" ,pcre)
@@ -397,6 +399,152 @@ documentation.")
"This package provides HTML documentation for the nginx web server.")
(license license:bsd-2))))
+(define-public nginx-accept-language-module
+ ;; Upstream has never made a release; use current commit instead.
+ (let ((commit "2f69842f83dac77f7d98b41a2b31b13b87aeaba7")
+ (revision "1"))
+ (package
+ (name "nginx-accept-language-module")
+ (version (git-version "0.0.0" ;upstream has no version number
+ revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/giom/nginx_accept_language_module.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hjysrl15kh5233w7apq298cc2bp4q1z5mvaqcka9pdl90m0vhbw"))))
+ (build-system gnu-build-system)
+ (inputs `(("openssl" ,openssl)
+ ("pcre" ,pcre)
+ ("nginx-sources" ,(package-source nginx))
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:tests? #f ; no test target
+ #:make-flags (list "modules")
+ #:modules ((guix build utils)
+ (guix build gnu-build-system)
+ (ice-9 popen)
+ (ice-9 regex)
+ (ice-9 textual-ports))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-nginx-sources
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (begin
+ ;; The nginx source code is part of the module’s source.
+ (format #t "decompressing nginx source code~%")
+ (call-with-output-file "nginx.tar"
+ (lambda (out)
+ (let* ((gzip (assoc-ref inputs "gzip"))
+ (nginx-srcs (assoc-ref inputs "nginx-sources"))
+ (pipe (open-pipe* OPEN_READ
+ (string-append gzip "/bin/gzip")
+ "-cd"
+ nginx-srcs)))
+ (dump-port pipe out)
+ (unless (= (status:exit-val (close-pipe pipe)) 0)
+ (error "gzip decompress failed")))))
+ (invoke (string-append (assoc-ref inputs "tar") "/bin/tar")
+ "xvf" "nginx.tar" "--strip-components=1")
+ (delete-file "nginx.tar")
+ #t)))
+ (add-after 'unpack 'convert-to-dynamic-module
+ (lambda _
+ (begin
+ (with-atomic-file-replacement "config"
+ (lambda (in out)
+ ;; cf. https://www.nginx.com/resources/wiki/extending/new_config/
+ (format out "ngx_module_type=HTTP~%")
+ (format out "ngx_module_name=\
+ngx_http_accept_language_module~%")
+ (let* ((str (get-string-all in))
+ (rx (make-regexp
+ "NGX_ADDON_SRCS=\"\\$NGX_ADDON_SRCS (.*)\""))
+ (m (regexp-exec rx str))
+ (srcs (match:substring m 1)))
+ (format out (string-append "ngx_module_srcs=\""
+ srcs "\"~%")))
+ (format out ". auto/module~%")
+ (format out "ngx_addon_name=$ngx_module_name~%"))))))
+ (add-before 'configure 'patch-/bin/sh
+ (lambda _
+ (substitute* "auto/feature"
+ (("/bin/sh") (which "sh")))
+ #t))
+ (replace 'configure
+ ;; This phase is largely copied from the nginx package.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((flags
+ (list ;; A copy of nginx’ flags follows, otherwise we
+ ;; get a binary compatibility error. FIXME: Code
+ ;; duplication is bad.
+ (string-append "--prefix=" (assoc-ref outputs "out"))
+ "--with-http_ssl_module"
+ "--with-http_v2_module"
+ "--with-pcre-jit"
+ "--with-debug"
+ ;; Even when not cross-building, we pass the
+ ;; --crossbuild option to avoid customizing for the
+ ;; kernel version on the build machine.
+ ,(let ((system "Linux") ; uname -s
+ (release "3.2.0") ; uname -r
+ ;; uname -m
+ (machine (match (or (%current-target-system)
+ (%current-system))
+ ("x86_64-linux" "x86_64")
+ ("i686-linux" "i686")
+ ("mips64el-linux" "mips64")
+ ;; Prevent errors when querying
+ ;; this package on unsupported
+ ;; platforms, e.g. when running
+ ;; "guix package --search="
+ (_ "UNSUPPORTED"))))
+ (string-append "--crossbuild="
+ system ":" release ":" machine))
+ ;; The following are the args decribed on
+ ;; <https://www.nginx.com/blog/compiling-dynamic-modules-nginx-plus>.
+ ;; Enabling --with-compat here and in the nginx package
+ ;; would ensure binary compatibility even when using
+ ;; different configure options from the main nginx
+ ;; package. This is not needed for Guix.
+ ;; "--with-compat"
+ "--add-dynamic-module=.")))
+ (setenv "CC" "gcc")
+ (format #t "environment variable `CC' set to `gcc'~%")
+ (format #t "configure flags: ~s~%" flags)
+ (apply invoke "./configure" flags)
+ #t)))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (modules-dir (string-append out "/etc/nginx/modules"))
+ (doc-dir (string-append
+ out "/share/doc/nginx-accept-language-module")))
+ (mkdir-p modules-dir)
+ (copy-file "objs/ngx_http_accept_language_module.so"
+ (string-append
+ modules-dir "/ngx_http_accept_language_module.so"))
+ (mkdir-p doc-dir)
+ (copy-file "README.textile"
+ (string-append doc-dir "/README.textile"))
+ #t))))))
+ (home-page
+ "https://www.nginx.com/resources/wiki/modules/accept_language/")
+ (synopsis "Nginx module for parsing the Accept-Language HTTP header")
+ (description
+ "This nginx module parses the Accept-Language field in HTTP headers and
+chooses the most suitable locale for the user from the list of locales
+supported at your website.")
+ (license (delete-duplicates
+ (cons license:bsd-2 ;license of nginx-accept-language-module
+ ;; The module’s code is linked statically with nginx,
+ ;; therefore nginx’ other licenses may also apply to its
+ ;; binary:
+ (package-license nginx)))))))
+
(define-public fcgi
(package
(name "fcgi")
@@ -2365,14 +2513,14 @@ HTTP requests.")
(define-public perl-cgi-simple
(package
(name "perl-cgi-simple")
- (version "1.21")
+ (version "1.22")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/M/MA/MANWAR/"
"CGI-Simple-" version ".tar.gz"))
(sha256
- (base32 "1wzc2igs4khmj7zfahvs87c24p9ks8hnqhhsyviyiix53xx2y6sg"))))
+ (base32 "13c7iwnnavky10ab87pi8jc1kqph03s0rhvj7myn7szhbfisc4gn"))))
(build-system perl-build-system)
(native-inputs
`(("perl-io-stringy" ,perl-io-stringy) ; for IO::Scalar
@@ -2862,7 +3010,7 @@ jar in conformance with RFC 6265 <http://tools.ietf.org/html/rfc6265>.")
(define-public perl-http-cookies
(package
(name "perl-http-cookies")
- (version "6.04")
+ (version "6.06")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2870,7 +3018,7 @@ jar in conformance with RFC 6265 <http://tools.ietf.org/html/rfc6265>.")
version ".tar.gz"))
(sha256
(base32
- "1m0kxcirbvbkrm2c59p1bkbvzlcdymg8fdpa7wlxijlx0xwz1iqc"))))
+ "13rnz3233vbsfariya4njiyfaj6k94j6bvlyh3dmfmh24hpqgx77"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-http-message" ,perl-http-message)))
@@ -3206,7 +3354,7 @@ select or poll.")
(define-public perl-libwww
(package
(name "perl-libwww")
- (version "6.39")
+ (version "6.41")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3214,7 +3362,7 @@ select or poll.")
version ".tar.gz"))
(sha256
(base32
- "1mblfwz3g7vmyykmb0mcbmmad77rwx55fwaca9ymv9wajd3pg3cs"))))
+ "0jh67946fwd33ap3xy8df0421d2mr6lmhalhkf1p7dx2b7fil9wf"))))
(build-system perl-build-system)
(native-inputs
`(("perl-test-fatal" ,perl-test-fatal)
@@ -4030,8 +4178,8 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(package-with-python2 python-feedparser))
(define-public guix-data-service
- (let ((commit "8019d2e6878908f40cb6b047f60d2e4fd3c6712e")
- (revision "3"))
+ (let ((commit "5e2bc7c6e920e1542ab8fde39dbddca443a7cbc8")
+ (revision "4"))
(package
(name "guix-data-service")
(version (string-append "0.0.1-" revision "." (string-take commit 7)))
@@ -4043,14 +4191,14 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(file-name (git-file-name name version))
(sha256
(base32
- "06xv43az1aklrdb5y0if17xdqc80qnfdlyjiww8zmv4m3qnvj607"))))
+ "0awfvps7k9bpg3gpgc93y401g7pjabx7mr9960vigad8vddhixqi"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; TODO Tests require PostgreSQL
- #:modules ((guix build utils)
+ '(#:modules ((guix build utils)
(guix build gnu-build-system)
(ice-9 rdelim)
(ice-9 popen))
+ #:test-target "check-with-tmp-database"
#:phases
(modify-phases %standard-phases
(add-after 'set-paths 'set-GUIX_ENVIRONMENT
@@ -4108,6 +4256,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
`(("guile" ,guile-2.2)
("autoconf" ,autoconf)
("automake" ,automake)
+ ("ephemeralpg" ,ephemeralpg)
("emacs-with-modules" ,(directory-union
"emacs-union"
(list emacs-no-x
@@ -5077,13 +5226,13 @@ deployments.")
(package
(name "varnish")
(home-page "https://varnish-cache.org/")
- (version "6.3.0")
+ (version "6.3.1")
(source (origin
(method url-fetch)
(uri (string-append home-page "_downloads/varnish-" version ".tgz"))
(sha256
(base32
- "0zwlffdd1m0ih33nq40xf2wwdyvr4czmns2fs90qpfnwy72xxk4m"))))
+ "0xa14pd68zpi5hxcax3arl14rcmh5d1cdwa8gv4l5f23mmynr8ni"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib")
@@ -5581,7 +5730,7 @@ snippets on @url{https://commandlinefu.com}.")
(define-public rss-bridge
(package
(name "rss-bridge")
- (version "2019-07-06")
+ (version "2019-09-12")
(source
(origin
(method git-fetch)
@@ -5590,8 +5739,7 @@ snippets on @url{https://commandlinefu.com}.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "0zd0c9xzvpx55mvj8xrafakfkvafnwkkvhw9b1j0bf897xdkfsyb"))))
+ (base32 "1mx7f3l45nqhcrng531l4cq8kpzm164hhbwn26g5akb2pamdlnra"))))
(build-system trivial-build-system)
(arguments
'(#:modules ((guix build utils))
@@ -5610,7 +5758,7 @@ snippets on @url{https://commandlinefu.com}.")
websites lacking feeds. Supported websites include Facebook, Twitter,
Instagram and YouTube.")
(license (list license:public-domain
- license:expat)))) ;; vendor/simplehtmldom/simple_html_dom.php
+ license:expat)))) ; vendor/simplehtmldom/simple_html_dom.php
(define-public linkchecker
(package
@@ -6395,6 +6543,36 @@ provides a very convenient API for extracting and manipulating data, using the
best of DOM, CSS, and jQuery-like methods.")
(license license:expat)))
+(define-public java-signpost-core
+ (package
+ (name "java-signpost-core")
+ (version "1.2.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mttkay/signpost")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l04yj2znch3hpyw90c4g4jan453w7d88l84bgl0c72i2kbb8z7h"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "signpost-core.jar"
+ #:source-dir "signpost-core/src/main/java"
+ #:test-dir "signpost-core/src/test"
+ ;; Tests all fail with InstantiationException from mockito
+ #:tests? #f))
+ (propagated-inputs
+ `(("java-commons-codec" ,java-commons-codec)))
+ (home-page "https://github.com/mttkay/signpost")
+ (synopsis "Lightweight client-side OAuth library for Java")
+ (description "Signpost is the easy and intuitive solution for signing
+HTTP messages on the Java platform in conformance with the OAuth Core 1.0a
+standard. Signpost follows a modular and flexible design, allowing you to
+combine it with different HTTP messaging layers.")
+ (license license:asl2.0)))
+
(define-public tidyp
(package
(name "tidyp")
@@ -6790,7 +6968,7 @@ Anonip can also be uses as a Python module in your own Python application.")
(build-system go-build-system)
(propagated-inputs
`(("go-github-com-robfig-cron" ,go-github-com-robfig-cron)
- ("go-golang-org-x-time-rate" ,go-golang-org-x-time-rate)))
+ ("go-golang-org-x-time" ,go-golang-org-x-time)))
(arguments
`(#:import-path "github.com/tsileo/poussetaches"))
(home-page "https://github.com/tsileo/poussetaches")