summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 23a4130b63..c0ed0f98a5 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1382,8 +1382,7 @@ current version of any major web browser.")
'(begin
;; Remove code using the problematic JSON license (see
;; <https://www.gnu.org/licenses/license-list.html#JSON>).
- (delete-file-recursively "bin/jsonchecker")
- #t))))
+ (delete-file-recursively "bin/jsonchecker")))))
(build-system cmake-build-system)
(arguments
(if (string-prefix? "aarch64" (or (%current-target-system)
@@ -1393,10 +1392,8 @@ current version of any major web browser.")
(add-after 'unpack 'patch-aarch-march-detection
(lambda _
(substitute* (find-files "." "^CMakeLists\\.txt$")
- (("native") "armv8-a"))
- #t))))
- ;; Disable CPU optimization for reproducibility.
- '(#:configure-flags '("-DRAPIDJSON_ENABLE_INSTRUMENTATION_OPT=OFF"))))
+ (("native") "armv8-a"))))))
+ '()))
(home-page "https://github.com/Tencent/rapidjson")
(synopsis "JSON parser/generator for C++ with both SAX/DOM style API")
(description