summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm34
1 files changed, 19 insertions, 15 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index fe7ebd5e1b..206520440d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -254,14 +254,14 @@
(define-public httpd
(package
(name "httpd")
- (version "2.4.48")
+ (version "2.4.51")
(source (origin
(method url-fetch)
(uri (string-append "mirror://apache/httpd/httpd-"
version ".tar.bz2"))
(sha256
(base32
- "0v4npxnvih5mlxx6dywwhhfs8xvgcckc0hxzwk3hi0g8nbkjdj0v"))))
+ "1x1qp10pfh33x1b56liwsjl0jamjm5lkk7j3lj87c1ygzs0ivq10"))))
(build-system gnu-build-system)
(native-inputs `(("pcre" ,pcre "bin"))) ;for 'pcre-config'
(inputs `(("apr" ,apr)
@@ -374,14 +374,14 @@ the same, being completely separated from the Internet.")
;; ’stable’ and recommends that “in general you deploy the NGINX mainline
;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
;; Please update the nginx-documentation package together with this one!
- (version "1.21.2")
+ (version "1.21.3")
(source (origin
(method url-fetch)
(uri (string-append "https://nginx.org/download/nginx-"
version ".tar.gz"))
(sha256
(base32
- "11ail85iw6mg8fxd2qnxhcghi0frjk5r70cfar83dms61rb1qxri"))))
+ "0nhps7igdqcpcy1r8677ar807rfclpylmz3y858a678m1np4lxql"))))
(build-system gnu-build-system)
(inputs `(("libxml2" ,libxml2)
("libxslt" ,libxslt)
@@ -476,9 +476,9 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
(define-public nginx-documentation
;; This documentation should be relevant for the current nginx package.
- (let ((version "1.21.2")
- (revision 2764)
- (changeset "bc9c5d11b67c"))
+ (let ((version "1.21.3")
+ (revision 2769)
+ (changeset "16f6fa718be2"))
(package
(name "nginx-documentation")
(version (simple-format #f "~A-~A-~A" version revision changeset))
@@ -490,7 +490,7 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
(file-name (string-append name "-" version))
(sha256
(base32
- "05n72q9vqxx37dyw3yl7jssmpqkw3rwxa2y3m6s0c0ih0z2bx58n"))))
+ "1rjq5xqzx843yk9nblz8lq14r4kmlrahap7m0lkvx5mky80vqp79"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no test suite
@@ -5909,6 +5909,7 @@ on the fly.")
("curl" ,curl)
("egrep" ,grep)
("lsof" ,lsof)
+ ("procps" ,procps)
("python" ,python)))
(inputs
`(("libev" ,libev)
@@ -5962,14 +5963,14 @@ tools like SSH (Secure Shell) to reach the outside world.")
(define-public stunnel
(package
(name "stunnel")
- (version "5.59")
+ (version "5.60")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.stunnel.org/downloads/stunnel-"
version ".tar.gz"))
(sha256
- (base32 "17yf2n47j5hw2y9527mrkx3j7q9jk5vvg46m3hgp1wg8dggpcxqk"))))
+ (base32 "0zbqiydyz9dvfg3axh18a42v6j3xvnwjbd03kgm1z1i12mdpcpf4"))))
(build-system gnu-build-system)
(native-inputs
;; For tests.
@@ -5989,16 +5990,19 @@ tools like SSH (Secure Shell) to reach the outside world.")
"doc/Makefile.in"
"tools/Makefile.in")
(("/doc/stunnel")
- (string-append "/doc/" ,name "-" ,version)))
- #t))
+ (string-append "/doc/" ,name "-" ,version)))))
(add-before 'check 'patch-tests
(lambda _
(substitute* "tests/make_test"
(("/bin/sh ")
(string-append (which "sh") " ")))
- ;; test requires networking
- (delete-file "tests/recipes/055_socket_closed")
- #t)))))
+ ;; This test requires networking.
+ (delete-file "tests/recipes/055_socket_closed")))
+ (add-after 'install 'prune-documentation
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (for-each delete-file (find-files doc "^INSTALL"))))))))
(home-page "https://www.stunnel.org")
(synopsis "TLS proxy for clients or servers")
(description "Stunnel is a proxy designed to add TLS encryption