summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 2866bad4f6..787b4a388a 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -163,16 +163,17 @@ interpretation of the specifications for these languages.")
(define-public vulkan-headers
(package
(name "vulkan-headers")
- (version "1.1.99")
+ (version "1.1.102")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/KhronosGroup/Vulkan-Headers")
(commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "166z6wn5kxnqm55zgzhmqa9hg48d11bfmi3wnf1mqhsx48xw6b8z"))))
+ "1dkjg48l7dfpq16bq1w9c3y9dwpj2hhv7b3njvj52lpgpa14s0f9"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; No tests.
@@ -193,9 +194,10 @@ interpretation of the specifications for these languages.")
(uri (git-reference
(url "https://github.com/KhronosGroup/Vulkan-Loader")
(commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "02m3sdcbl8s6qr1nsba5621vg3f4akkfaa7g9hi70cpvws4x0gg8"))))
+ "0ccpklv251jcz2lxvd5ix5i3cg4wb7qq5xi6cwvniy1rw52z7h00"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;FIXME: 23/39 tests fail. Try "tests/run_all_tests.sh".
@@ -242,16 +244,17 @@ and the ICD.")
(define-public vulkan-tools
(package
(name "vulkan-tools")
- (version "1.1.97.0")
+ (version "1.1.101")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/KhronosGroup/Vulkan-Tools")
- (commit (string-append "sdk-" version))))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1p70wk0x546w1dlvlghrqm4l4b6ql0x08pdybyagnwwph0gdvqy3"))))
+ "0qms8xjl0i9ajrckxkcq7rj28zjby4gbr1vz8xxkmgfbani8mai4"))))
(build-system cmake-build-system)
(inputs
`(("glslang" ,glslang)
@@ -264,7 +267,10 @@ and the ICD.")
`(("pkg-config" ,pkg-config)
("python" ,python)))
(arguments
- `(#:tests? #f)) ; No tests.
+ `(#:tests? #f ; No tests.
+ #:configure-flags (list "-DBUILD_ICD=off" ; FIXME: Doesn't build.
+ (string-append "-DGLSLANG_INSTALL_DIR="
+ (assoc-ref %build-inputs "glslang")))))
(home-page
"https://github.com/KhronosGroup/Vulkan-Tools")
(synopsis "Tools and utilities for Vulkan")