summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm64
1 files changed, 31 insertions, 33 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index ac91f8451c..f5c619a2b2 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
@@ -91,9 +93,8 @@ and for the GLSL.std.450 extended instruction set.
(string-append
"-DSPIRV-Headers_SOURCE_DIR="
(assoc-ref %build-inputs "spirv-headers")))))
- (inputs `(("spirv-headers" ,spirv-headers)))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("python" ,python)))
+ (inputs (list spirv-headers))
+ (native-inputs (list pkg-config python))
(home-page "https://github.com/KhronosGroup/SPIRV-Tools")
(synopsis "API and commands for processing SPIR-V modules")
(description
@@ -136,10 +137,8 @@ parser,disassembler, validator, and optimizer for SPIR-V.")
(string-append (assoc-ref inputs "spirv-tools") "/bin")))
#t)))))
(inputs
- `(("glslang" ,glslang)
- ("spirv-headers" ,spirv-headers)
- ("spirv-tools" ,spirv-tools)))
- (native-inputs `(("python" ,python)))
+ (list glslang spirv-headers spirv-tools))
+ (native-inputs (list python))
(home-page "https://github.com/KhronosGroup/SPIRV-Cross")
(synopsis "Parser for and converter of SPIR-V to other shader languages")
(description
@@ -168,8 +167,7 @@ SPIR-V, aiming to emit GLSL or MSL that looks like human-written code.")
'(#:tests? #f ;FIXME: requires bundled SPIRV-Tools
#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python)))
+ (list pkg-config python))
(home-page "https://github.com/KhronosGroup/glslang")
(synopsis "OpenGL and OpenGL ES shader front end and validator")
(description
@@ -222,7 +220,14 @@ interpretation of the specifications for these languages.")
"15gx9ab6w1sjq9hkpbas7z2f8f47j6mlln6p3w26qmydjj8gfjjv"))))
(build-system cmake-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
+ `(#:configure-flags
+ ,#~(list
+ (string-append "-DVULKAN_HEADERS_INSTALL_DIR="
+ #$(this-package-input "vulkan-headers"))
+ (string-append "-DCMAKE_INSTALL_INCLUDEDIR="
+ #$(this-package-input "vulkan-headers")
+ "/include"))
+ #:phases (modify-phases %standard-phases
(add-after 'unpack 'unpack-googletest
(lambda* (#:key inputs #:allow-other-keys)
(let ((gtest (assoc-ref inputs "googletest:source")))
@@ -243,8 +248,9 @@ interpretation of the specifications for these languages.")
("libxrandr" ,libxrandr)
("pkg-config" ,pkg-config)
("python" ,python)
- ("vulkan-headers" ,vulkan-headers)
("wayland" ,wayland)))
+ (inputs
+ (list vulkan-headers))
(home-page
"https://github.com/KhronosGroup/Vulkan-Loader")
(synopsis "Khronos official ICD loader and validation layers for Vulkan")
@@ -276,14 +282,9 @@ and the ICD.")
"129wzk7xj3vn3c8b4p7fzkd0npl58118s2i1d88gsfnlix54nagq"))))
(build-system cmake-build-system)
(inputs
- `(("glslang" ,glslang)
- ("libxrandr" ,libxrandr)
- ("vulkan-loader" ,vulkan-loader)
- ("wayland" ,wayland)))
+ (list glslang libxrandr vulkan-loader wayland))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python)
- ("vulkan-headers" ,vulkan-headers)))
+ (list pkg-config python vulkan-headers))
(arguments
`(#:tests? #f ;no tests
#:configure-flags (list (string-append "-DGLSLANG_INSTALL_DIR="
@@ -344,12 +345,9 @@ API.")
,(package-version glslang))))
#t)))))
(inputs
- `(("glslang" ,glslang)
- ("python" ,python)
- ("spirv-headers" ,spirv-headers)
- ("spirv-tools" ,spirv-tools)))
+ (list glslang python spirv-headers spirv-tools))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(home-page "https://github.com/google/shaderc")
(synopsis "Tools for shader compilation")
(description "Shaderc is a collection of tools, libraries, and tests for
@@ -390,16 +388,16 @@ shader compilation.")
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(inputs
- `(("libx11" ,libx11)
- ("libxcb" ,libxcb)
- ("spirv-headers" ,spirv-headers)
- ("spirv-tools" ,spirv-tools)
- ("vulkan-headers" ,vulkan-headers)
- ("vulkan-loader" ,vulkan-loader)
- ("wine-minimal" ,wine-minimal) ; Needed for 'widl'.
- ("xcb-util" ,xcb-util)
- ("xcb-util-keysyms" ,xcb-util-keysyms)
- ("xcb-util-wm" ,xcb-util-wm)))
+ (list libx11
+ libxcb
+ spirv-headers
+ spirv-tools
+ vulkan-headers
+ vulkan-loader
+ wine-minimal ; Needed for 'widl'.
+ xcb-util
+ xcb-util-keysyms
+ xcb-util-wm))
(home-page "https://source.winehq.org/git/vkd3d.git/")
(synopsis "Direct3D 12 to Vulkan translation library")
(description "vkd3d is a library for translating Direct3D 12 to Vulkan.")