summaryrefslogtreecommitdiff
path: root/gnu/packages/vtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vtk.scm')
-rw-r--r--gnu/packages/vtk.scm50
1 files changed, 39 insertions, 11 deletions
diff --git a/gnu/packages/vtk.scm b/gnu/packages/vtk.scm
index 13ce2e2ac0..5a5c941270 100644
--- a/gnu/packages/vtk.scm
+++ b/gnu/packages/vtk.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,37 +21,64 @@
(define-module (gnu packages vtk)
#:use-module (guix packages)
#:use-module (guix download)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:select (bsd-3))
+ #:use-module (guix utils)
#:use-module (guix build-system cmake)
#:use-module (gnu packages)
- #:use-module (gnu packages xorg)
- #:use-module (gnu packages gl))
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gl)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages serialization)
+ #:use-module (gnu packages xiph)
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg))
(define-public vtk
(package
(name "vtk")
- (version "6.1.0")
+ (version "7.1.0")
(source (origin
(method url-fetch)
(uri (string-append "http://www.vtk.org/files/release/"
- (substring version 0
- (string-rindex version #\.))
+ (version-major+minor version)
"/VTK-" version ".tar.gz"))
(sha256
(base32
- "0d7shccdkyj4mbh2riilslgx3gd28in4c7xpm0lxa1ln8w5g2zdx"))
- (patches (search-patches "vtk-mesa-10.patch"))))
+ "0yj96z58haan77gzilnqp7xpf8hg5jk11a3jx55p2ksd400s0gjz"))))
(build-system cmake-build-system)
(arguments
- ;; Build without '-g' to save space.
- '(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")
+ '(#:build-type "Release" ;Build without '-g' to save space.
+ ;; -DVTK_USE_SYSTEM_NETCDF:BOOL=TRUE requires netcdf_cxx
+ #:configure-flags '("-DVTK_USE_SYSTEM_EXPAT:BOOL=TRUE"
+ "-DVTK_USE_SYSTEM_FREETYPE:BOOL=TRUE"
+ "-DVTK_USE_SYSTEM_HDF5:BOOL=TRUE"
+ "-DVTK_USE_SYSTEM_JPEG:BOOL=TRUE"
+ "-DVTK_USE_SYSTEM_JSONCPP:BOOL=TRUE"
+ "-DVTK_USE_SYSTEM_LIBXML2:BOOL=TRUE"
+ "-DVTK_USE_SYSTEM_OGGTHEORA:BOOL=TRUE"
+ "-DVTK_USE_SYSTEM_PNG:BOOL=TRUE"
+ "-DVTK_USE_SYSTEM_TIFF:BOOL=TRUE"
+ "-DVTK_USE_SYSTEM_ZLIB:BOOL=TRUE")
#:tests? #f)) ;XXX: no "test" target
(inputs
`(("libXt" ,libxt)
("xproto" ,xproto)
("libX11" ,libx11)
+ ("libxml2" ,libxml2)
("mesa" ,mesa)
- ("glu" ,glu)))
+ ("glu" ,glu)
+ ("expat" ,expat)
+ ("freetype" ,freetype)
+ ("hdf5" ,hdf5)
+ ("jpeg" ,libjpeg)
+ ("jsoncpp" ,jsoncpp)
+ ("libogg" ,libogg)
+ ("libtheora" ,libtheora)
+ ("png" ,libpng)
+ ("tiff" ,libtiff)
+ ("zlib" ,zlib)))
(home-page "http://www.vtk.org/")
(synopsis "Libraries for 3D computer graphics")
(description