summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index e6a2f42ee3..65cf5bd355 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -227,7 +227,7 @@ the entire VPN in a network namespace accessible only through SSH.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/cernekee/ocproxy.git")
+ (url "https://github.com/cernekee/ocproxy")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -327,7 +327,7 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
;; Thus, fetch code from Git.
(method git-fetch)
(uri (git-reference
- (url "https://github.com/ProtonVPN/linux-cli.git")
+ (url "https://github.com/ProtonVPN/linux-cli")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -462,7 +462,7 @@ with configuration options for most of @command{sshuttle}’s features.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/ambrop72/badvpn.git")
+ (url "https://github.com/ambrop72/badvpn")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -501,7 +501,7 @@ The peer-to-peer VPN implements a Layer 2 (Ethernet) network between the peers
(define-public wireguard-linux-compat
(package
(name "wireguard-linux-compat")
- (version "1.0.20200520")
+ (version "1.0.20200623")
(source (origin
(method url-fetch)
(uri (string-append "https://git.zx2c4.com/wireguard-linux-compat/"
@@ -509,7 +509,7 @@ The peer-to-peer VPN implements a Layer 2 (Ethernet) network between the peers
".tar.xz"))
(sha256
(base32
- "1hvpbfpdd3v2k27ypa1y1j422irx7hxpz87f50s28jvkxx5sxrqn"))))
+ "0iclixsqfckaz6kz6a4lhzdary3xhfy1d0pz0pgrwy8m8mr3f28k"))))
(build-system linux-module-build-system)
(outputs '("out"
"kernel-patch"))