summaryrefslogtreecommitdiff
path: root/gnu/packages/virtualization.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/virtualization.scm')
-rw-r--r--gnu/packages/virtualization.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index b7e2c415fe..be17ec15f0 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2017, 2018. 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
@@ -129,9 +129,15 @@
"1w38hzlw7xp05gcq1nhga7hxvndxy6dfcnzi7q2il8ff110isj6k"))))
(build-system gnu-build-system)
(arguments
- '(;; Running tests in parallel can occasionally lead to failures, like:
+ `(;; Running tests in parallel can occasionally lead to failures, like:
;; boot_sector_test: assertion failed (signature == SIGNATURE): (0x00000000 == 0x0000dead)
#:parallel-tests? #f
+
+ ;; FIXME: Disable tests on i686 to work around
+ ;; <https://bugs.gnu.org/40527>.
+ #:tests? ,(or (%current-target-system)
+ (not (string=? "i686-linux" (%current-system))))
+
#:configure-flags (list "--enable-usb-redir" "--enable-opengl"
"--enable-docs"
(string-append "--smbd="
@@ -891,9 +897,6 @@ monitor/GPU.")
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:gpl2+))))
-(define-public lookingglass
- (deprecated-package "lookingglass" looking-glass-client))
-
(define-public runc
(package
(name "runc")
@@ -1086,7 +1089,7 @@ virtual machines.")
(define-public bubblewrap
(package
(name "bubblewrap")
- (version "0.4.0")
+ (version "0.4.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/containers/bubblewrap/"
@@ -1094,7 +1097,7 @@ virtual machines.")
version ".tar.xz"))
(sha256
(base32
- "08r0f4c3fjkb4zjrb4kkax1zfcgcgic702vb62sjjw5xfhppvzp5"))))
+ "00ycgi6q2yngh06bnz50wkvar6r2jnjf3j158grhi9k13jdrpimr"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1170,7 +1173,7 @@ DOS or Microsoft Windows.")
(define-public xen
(package
(name "xen")
- (version "4.11.1")
+ (version "4.13.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1179,7 +1182,7 @@ DOS or Microsoft Windows.")
(file-name (git-file-name name version))
(sha256
(base32
- "1wv1hyfii14vi9lfjmnv07h2gpm3b7kvh2p55f4yy2b40simksgk"))))
+ "0py50n995gv909i0d1lfdcj9wcp5g1d5z6m2291jqqlfyany138g"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -1293,14 +1296,13 @@ override CC = " (assoc-ref inputs "cross-gcc") "/bin/i686-linux-gnu-gcc"))
new-search-path ":")))
(setenv env-name new-env-value)))
environment-variable-names))
- (setenv "CROSS_C_INCLUDE_PATH" (getenv "C_INCLUDE_PATH"))
- (setenv "CROSS_CPLUS_INCLUDE_PATH" (getenv "CPLUS_INCLUDE_PATH"))
+ (setenv "CROSS_CPATH" (getenv "CPATH"))
(setenv "CROSS_LIBRARY_PATH" (getenv "LIBRARY_PATH"))
(filter-environment! cross?
- '("CROSS_C_INCLUDE_PATH" "CROSS_CPLUS_INCLUDE_PATH"
+ '("CROSS_CPATH"
"CROSS_LIBRARY_PATH"))
(filter-environment! (lambda (e) (not (cross? e)))
- '("C_INCLUDE_PATH" "CPLUS_INCLUDE_PATH"
+ '("CPATH"
"LIBRARY_PATH"))
;; Guix tries to be helpful and automatically adds
;; mini-os-git-checkout/include to the include path,
@@ -1309,7 +1311,7 @@ override CC = " (assoc-ref inputs "cross-gcc") "/bin/i686-linux-gnu-gcc"))
(not
(string-contains e
"mini-os-git-checkout")))
- '("C_INCLUDE_PATH" "CPLUS_INCLUDE_PATH"
+ '("CPATH"
"LIBRARY_PATH"))
(setenv "EFI_VENDOR" "guix")
#t))