summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 81d5ab00c9..da4404e23c 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -145,7 +145,14 @@
;; Blindly fix some other differences based on error output.
(("^\\|!") "|<")
(("@37") "")))
- #t)))))
+ #t))
+ (add-after 'install 'install-guix.vim
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((vimdir (string-append (assoc-ref outputs "out") "/share/vim")))
+ (mkdir-p vimdir)
+ (copy-file (assoc-ref inputs "guix.vim")
+ (string-append vimdir "/vimrc"))
+ #t))))))
(inputs
`(("gawk" ,gawk)
("ncurses" ,ncurses)
@@ -153,6 +160,7 @@
("tcsh" ,tcsh))) ; For runtime/tools/vim32
(native-inputs
`(("libtool" ,libtool)
+ ("guix.vim" ,(search-auxiliary-file "guix.vim"))
;; For tests.
("tzdata" ,tzdata-for-tests)))
@@ -808,9 +816,6 @@ also works as a library for connecting to and scripting neovim processes
through its msgpack-rpc API.")
(license license:asl2.0)))
-(define-public python2-pynvim
- (package-with-python2 python-pynvim))
-
(define-public vim-guix-vim
(package
(name "vim-guix-vim")