summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm60
1 files changed, 49 insertions, 11 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 5338d375ee..d953ca0fd4 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015, 2016 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2015, 2016, 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Dmitry Nikolaev <cameltheman@gmail.com>
@@ -980,7 +980,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(define-public mpv
(package
(name "mpv")
- (version "0.25.0")
+ (version "0.26.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -988,7 +988,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
".tar.gz"))
(sha256
(base32
- "1khb7c4fdj1aak46lwyb3lq14w5jpxzws0zp6bdc87ljsvx3yhh7"))
+ "0ihvnwrp24jjf43k1hvy8n8w4ipl4z7apjppd4i0y9jzilsyzwys"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system waf-build-system)
(native-inputs
@@ -1055,7 +1055,7 @@ projects while introducing many more.")
(define-public gnome-mpv
(package
(name "gnome-mpv")
- (version "0.11")
+ (version "0.12")
(source
(origin
(method url-fetch)
@@ -1064,7 +1064,7 @@ projects while introducing many more.")
".tar.xz"))
(sha256
(base32
- "1hn3mpsxbrwf2m0nz4vzji4i6i896y8kqjb9kijqpk04cnrs3fgz"))))
+ "0dcnz9vlf791v8d15j7hpymv87h6nb15alww6xjq0zpal5hi44kc"))))
(native-inputs
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)))
@@ -1121,7 +1121,7 @@ access to mpv's powerful playback capabilities.")
(define-public youtube-dl
(package
(name "youtube-dl")
- (version "2017.07.09")
+ (version "2017.07.23")
(source (origin
(method url-fetch)
(uri (string-append "https://yt-dl.org/downloads/"
@@ -1129,7 +1129,7 @@ access to mpv's powerful playback capabilities.")
version ".tar.gz"))
(sha256
(base32
- "0phrfby2nk5y5x5173bbg3jcr2ajk849al3zji5y39z39dj36ba2"))))
+ "0h8jim7qx7b97wg7s8izz3and1xp70b9clqwpxl33xls9linh04m"))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion
@@ -1888,6 +1888,44 @@ your graphical desktop and encodes it as a video. This is a useful tool for
making @dfn{screencasts}.")
(license license:gpl2+)))
+(define-public simplescreenrecorder
+ (package
+ (name "simplescreenrecorder")
+ (version "0.3.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/MaartenBaert/ssr/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0v8w35n8w772s08w7k0icynqdsdakbrcanbgx6j847bfqfsg21gg"))))
+ (build-system gnu-build-system)
+ ;; Although libx11, libxfixes, libxext are listed as build dependencies in
+ ;; README.md, the program builds and functions properly without them.
+ ;; As a result, they are omitted. Please add them back if problems appear.
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("ffmpeg" ,ffmpeg)
+ ("glu" ,glu)
+ ("jack" ,jack-1)
+ ("libxi" ,libxi)
+ ("pulseaudio" ,pulseaudio)
+ ("qt" ,qt-4))) ; README.md: using Qt 5 causes some stability issues
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ ;; Using HTTPS causes part of the page to be displayed improperly.
+ (home-page "http://www.maartenbaert.be/simplescreenrecorder/")
+ (synopsis "Screen recorder")
+ (description "SimpleScreenRecorder is an easy to use screen recorder with
+a graphical user interface. It supports recording the entire screen, or a
+part of it, and allows encoding in many different codecs and file formats.
+Other features include a live preview and live streaming.")
+ (license (list license:gpl3+ ; most files
+ license:zlib ; glinject/elfhacks.*
+ license:isc ; glinject/*
+ license:x11)))) ; build-aux/install-sh
+
(define-public libsmpeg
(package
(name "libsmpeg")
@@ -1932,7 +1970,7 @@ and MPEG system streams.")
(source
(origin
(method url-fetch)
- (uri (string-append "ftp://ftp.videolan.org/pub/videolan/libbdplus/"
+ (uri (string-append "https://ftp.videolan.org/pub/videolan/libbdplus/"
version "/" name "-" version ".tar.bz2"))
(sha256
(base32 "02n87lysqn4kg2qk7d1ffrp96c44zkdlxdj0n16hbgrlrpiwlcd6"))))
@@ -1952,7 +1990,7 @@ specifications.")
(source
(origin
(method url-fetch)
- (uri (string-append "ftp://ftp.videolan.org/pub/videolan/libaacs/"
+ (uri (string-append "https://ftp.videolan.org/pub/videolan/libaacs/"
version "/" name "-" version ".tar.bz2"))
(sha256
(base32 "1kms92i0c7i1yl659kqjf19lm8172pnpik5lsxp19xphr74vvq27"))))
@@ -2108,7 +2146,7 @@ of modern, widely supported codecs.")
(define-public openh264
(package
(name "openh264")
- (version "1.6.0")
+ (version "1.7.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/cisco/"
@@ -2116,7 +2154,7 @@ of modern, widely supported codecs.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1ix2fhk62i4q4kbnkl0gfk4x53vxqavsn0pck1pashr566zhglv5"))))
+ "0gv571bqkxk7ic64dmavs1q8nr7p59mcf4ibqp4lc070gn6w61ww"))))
(build-system gnu-build-system)
(native-inputs
`(("nasm" ,nasm)