summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm61
1 files changed, 54 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 452974dd3a..2830aaacd1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4,15 +4,14 @@
;;; Copyright © 2014, 2015, 2016, 2018, 2020 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2015 Andy Patterson <ajpatter@uwaterloo.ca>
+;;; Copyright © 2015, 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2015, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Dmitry Nikolaev <cameltheman@gmail.com>
-;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2016, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2016, 2018, 2019, 2020, 2021 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Feng Shu <tumashu@163.com>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -54,6 +53,7 @@
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Thiago Jung Bauermann <bauermann@kolabnow.com>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -453,6 +453,51 @@ library.")
(home-page "http://libquicktime.sourceforge.net/")
(license license:lgpl2.1+)))
+(define-public mjpg-streamer
+ (package
+ (name "mjpg-streamer")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jacksonliam/mjpg-streamer")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0w81pg228154blzbzr590xwhcll9baxyqxl6wxrgqsi9cd7pzq23"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (with-directory-excursion "mjpg-streamer-experimental/www"
+ (for-each delete-file-recursively
+ '("cambozola.jar"
+ "JQuerySpinBtn.css"
+ "JQuerySpinBtn.js"
+ "jquery.js"
+ "jquery.rotate.js"
+ "jquery.ui.core.min.js"
+ "jquery.ui.custom.css"
+ "jquery.ui.tabs.min.js"
+ "jquery.ui.widget.min.js")))))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda* _
+ (chdir "mjpg-streamer-experimental"))))))
+ (inputs `(("libjpeg-turbo" ,libjpeg-turbo)))
+ (synopsis "Stream JPEG over IP network")
+ (description "Command line application that copies JPEG frames from one or
+more input plugins to multiple output plugins. It can be used to stream JPEG
+files over an IP-based network from a webcam to various types of viewers such
+as Chrome, Firefox, Cambozola, VLC, mplayer, and other software capable of
+receiving MJPG streams.")
+ (home-page "https://github.com/jacksonliam/mjpg-streamer")
+ (license license:gpl2+)))
+
(define-public mjpegtools
(package
(name "mjpegtools")
@@ -3654,7 +3699,7 @@ supported players in addition to this package.")
(define-public handbrake
(package
(name "handbrake")
- (version "1.3.3")
+ (version "1.4.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/HandBrake/HandBrake/"
@@ -3662,7 +3707,7 @@ supported players in addition to this package.")
"HandBrake-" version "-source.tar.bz2"))
(sha256
(base32
- "11bzhyp052bmng5119x74xvdj5632smx6qsk537ygda8bzckg2i1"))
+ "1xhq9jjmf854jf7sg4m754hgajnavwwhmjnaikcf2vgjr35ax81r"))
(modules '((guix build utils)))
(snippet
;; Remove "contrib" and source not necessary for
@@ -3703,6 +3748,7 @@ supported players in addition to this package.")
("libdvdnav" ,libdvdnav)
("libdvdread" ,libdvdread)
("libgudev" ,libgudev)
+ ("libjpeg-turbo" ,libjpeg-turbo)
("libmpeg2" ,libmpeg2)
("libnotify" ,libnotify)
("libnuma" ,numactl)
@@ -3716,6 +3762,7 @@ supported players in addition to this package.")
("libx264" ,libx264)
("speex" ,speex)
("x265" ,x265)
+ ("zimg" ,zimg)
("zlib" ,zlib)))
(arguments
`(#:tests? #f ;tests require Ruby and claim to be unsupported
@@ -4677,7 +4724,7 @@ transitions, and effects and then export your film to many common formats.")
(define-public shotcut
(package
(name "shotcut")
- (version "21.08.29")
+ (version "21.09.20")
(source
(origin
(method git-fetch)
@@ -4686,7 +4733,7 @@ transitions, and effects and then export your film to many common formats.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0lj3ini0fymvcwxk8l1l8ms5519n5n87gdvh0yfhilwp0zqyqkc6"))))
+ (base32 "1y46n5gmlayfl46l0vhg5g5dbbc0sg909mxb68sia0clkaas8xrh"))))
(build-system qt-build-system)
(arguments
`(#:tests? #f ;there are no tests