summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 60469d6d89..fdc8b02a5a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2332,10 +2332,11 @@ MPEG-2, MPEG-4, DVD (VOB)...
#:phases
;; build scripts not in root of archive
(modify-phases %standard-phases
- (add-before 'configure 'pre-configure
+ (add-after 'unpack 'change-to-build-dir
(lambda _
- (chdir "Project/GNU/CLI")))
- (add-after 'unpack 'autogen
+ (chdir "Project/GNU/CLI")
+ #t))
+ (add-after 'change-to-build-dir 'autogen
(lambda _
(zero? (system* "sh" "autogen.sh")))))))
(home-page "https://mediaarea.net/en/MediaInfo")