summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm30
1 files changed, 17 insertions, 13 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 1314c459f5..d0186a1b6f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1611,7 +1611,7 @@ To load this plugin, specify the following option when starting mpv:
(define-public youtube-dl
(package
(name "youtube-dl")
- (version "2020.05.08")
+ (version "2020.05.29")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ytdl-org/youtube-dl/"
@@ -1619,7 +1619,7 @@ To load this plugin, specify the following option when starting mpv:
version ".tar.gz"))
(sha256
(base32
- "16zxa8ss2rka7cvkqyi67s8i1h9f4nxx88w9vjbxchbga6w0scc6"))))
+ "111ganbfi76ipfq5gjgamjbqd7m8l4lim9wwmfnc04bzvwqqzfi3"))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion
@@ -1798,7 +1798,7 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
(define-public youtube-viewer
(package
(name "youtube-viewer")
- (version "3.7.5")
+ (version "3.7.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1807,7 +1807,7 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
(file-name (git-file-name name version))
(sha256
(base32
- "1caz56sxy554avz2vdv9gm7gyqcq0gyixzrh5v9ixmg6vxif5d4f"))))
+ "1c7wynx0fzs8awb1s4rdrl8xavqlj64z95yckhl1m1gnhahhq291"))))
(build-system perl-build-system)
(native-inputs
`(("perl-module-build" ,perl-module-build)))
@@ -2888,18 +2888,22 @@ of modern, widely supported codecs.")
(define-public intel-vaapi-driver
(package
(name "intel-vaapi-driver")
- (version "2.4.0")
+ (version "2.4.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/intel/intel-vaapi-driver/"
- "releases/download/" version "/intel-vaapi-driver-"
- version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/intel/intel-vaapi-driver")
+ (commit version)))
(sha256
- (base32 "12fhydgwpvyh97gxqlgv77wsf9yax321h46vi49j4sxghpcxvqki"))))
+ (base32 "1cidki3av9wnkgwi7fklxbg3bh6kysf8w3fk2qadjr05a92mx3zp"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(inputs
`(("libdrm" ,libdrm)
("libva" ,libva)
@@ -2933,7 +2937,7 @@ post-processing of video formats like MPEG2, H.264/AVC, and VC-1.")
(define-public openh264
(package
(name "openh264")
- (version "2.1.0")
+ (version "2.1.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2942,7 +2946,7 @@ post-processing of video formats like MPEG2, H.264/AVC, and VC-1.")
(file-name (git-file-name name version))
(sha256
(base32
- "1wba260n1932vafd5ni2jqv9kzc7lj6a1asm1cqk8jv690m6zvpi"))))
+ "0ffav46pz3sbj92nipd62z03fibyqgclfq9w8lgr80s6za6zdk5s"))))
(build-system gnu-build-system)
(native-inputs
`(("nasm" ,nasm)