summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b4a40f6ea6..824ea62273 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -247,7 +247,7 @@
("faac" ,faac)
("ffmpeg" ,ffmpeg)
("freetype" ,freetype)
- ("imagemagick" ,imagemagick-next)
+ ("imagemagick" ,imagemagick)
("lame" ,lame)
("liba52" ,liba52)
("libdv" ,libdv)
@@ -1329,19 +1329,14 @@ libebml is a C++ library to read and write EBML files.")
(define-public libva
(package
(name "libva")
- (version "2.9.0")
+ (version "2.10.0")
(source
(origin
(method url-fetch)
- (uri (list
- ;; Newer releases are only available on GitHub.
- (string-append "https://github.com/01org/libva/releases/download/"
- version "/libva-" version ".tar.bz2")
- ;; Keep the old URL around for compatibility.
- (string-append "https://www.freedesktop.org/software/vaapi/releases/"
- "libva/libva-" version "/libva-" version ".tar.bz2")))
+ (uri (string-append "https://github.com/intel/libva/releases/download/"
+ version "/libva-" version ".tar.bz2"))
(sha256
- (base32 "0jsq6ia3fzyzvq7lxsrn4a8kn2kx4z3v777xkxn6k4ny5lww2i73"))))
+ (base32 "0dh2zjn6wi74ga75r6pbrrj8hjm213zyxvn9bv78z0fra1dy70gs"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -1777,6 +1772,7 @@ videoformats depend on the configuration flags of ffmpeg.")
"https://download.videolan.org/pub/videolan/vlc/"
(car (string-split version #\-))
"/vlc-" version ".tar.xz"))
+ (patches (search-patches "vlc-qt-5.15.patch"))
(sha256
(base32
"1f46h0hv7fk35zg4iczlp7ib7h2jmh8m4r5klw3g2558ib9134qq"))))