summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm44
1 files changed, 23 insertions, 21 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 61560d5fe7..ec7f9e8a3c 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -166,25 +166,28 @@ as well as the classic centralized workflow.")
#:modules ((srfi srfi-1)
,@%gnu-build-system-modules)
#:phases
- (alist-cons-after
- 'configure 'patch-makefile-shebangs
- (lambda _
- (substitute* "Makefile"
- (("/bin/sh") (which "sh"))
- (("/usr/bin/perl") (which "perl"))
- (("/usr/bin/python") (which "python"))))
- (alist-cons-after
- 'install 'install-shell-completion
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (completions (string-append out "/etc/bash_completion.d")))
- ;; TODO: Install the tcsh and zsh completions in the right place.
- (mkdir-p completions)
- (copy-file "contrib/completion/git-completion.bash"
- (string-append completions "/git"))
- #t))
- (alist-cons-after
- 'install 'split
+ (modify-phases %standard-phases
+ (add-after 'configure 'patch-makefile-shebangs
+ (lambda _
+ (substitute* "Makefile"
+ (("/bin/sh") (which "sh"))
+ (("/usr/bin/perl") (which "perl"))
+ (("/usr/bin/python") (which "python")))))
+ (add-after 'configure 'add-PM.stamp
+ (lambda _
+ ;; Add the "PM.stamp" to avoid "no rule to make target".
+ (call-with-output-file "perl/PM.stamp" (const #t))
+ #t))
+ (add-after 'install 'install-shell-completion
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (completions (string-append out "/etc/bash_completion.d")))
+ ;; TODO: Install the tcsh and zsh completions in the right place.
+ (mkdir-p completions)
+ (copy-file "contrib/completion/git-completion.bash"
+ (string-append completions "/git"))
+ #t)))
+ (add-after 'install 'split
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Split the binaries to the various outputs.
(let* ((out (assoc-ref outputs "out"))
@@ -256,8 +259,7 @@ as well as the classic centralized workflow.")
;; specify a single directory, not a search path.
(wrap-program (string-append out "/bin/git")
`("PATH" ":" prefix
- ("$HOME/.guix-profile/libexec/git-core")))))
- %standard-phases)))))
+ ("$HOME/.guix-profile/libexec/git-core")))))))))
(native-search-paths
;; For HTTPS access, Git needs a single-file certificate bundle, specified