summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 99e1a8ccd1..d2a24c7571 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -154,14 +154,14 @@ as well as the classic centralized workflow.")
(define-public git
(package
(name "git")
- (version "2.26.2")
+ (version "2.27.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "0j685w6pzkn926z5nf5r8fij4ziipvw4c9yb0wc577nzf4j16rbd"))))
+ "1ybk39ylvs32lywq7ra4l2kdr5izc80r9461hwfnw8pssxs9gjkk"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -178,7 +178,7 @@ as well as the classic centralized workflow.")
version ".tar.xz"))
(sha256
(base32
- "0rb4f4jc31zrcg4gyjg4fi07dw7nggkjg2nqfiq5p1aayw2f2ga3"))))
+ "176lkcfhjhqin2w8s814j9wwcian9jr6xx6xzn35i5scn14spjz6"))))
;; For subtree documentation.
("asciidoc" ,asciidoc-py3)
("docbook-xsl" ,docbook-xsl)
@@ -302,12 +302,12 @@ as well as the classic centralized workflow.")
;; specified in the XML, unlike the above substitution. Instead it
;; uses a hard-coded URL. Work around it here, but if this is
;; common perhaps we should hardcode this path in xmlto itself.
- (("\\$\\(XMLTO\\) -m \\$\\(MANPAGE_XSL\\) man")
+ (("\\$\\(XMLTO\\) -m \\$\\(MANPAGE_XSL\\)")
(string-append "$(XMLTO) -x "
(string-append (assoc-ref inputs "docbook-xsl")
"/xml/xsl/docbook-xsl-"
,(package-version docbook-xsl))
- "/manpages/docbook.xsl -m $(MANPAGE_XSL) man")))
+ "/manpages/docbook.xsl -m $(MANPAGE_XSL)")))
(invoke "make")
(invoke "make" "install")
(invoke "make" "install-doc")
@@ -723,7 +723,7 @@ write native speed custom Git applications in any language with bindings.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/AGWA/git-crypt.git")
+ (url "https://github.com/AGWA/git-crypt")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -971,7 +971,7 @@ repository")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/davisp/ghp-import.git")
+ (url "https://github.com/davisp/ghp-import")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -1102,7 +1102,7 @@ either a pure Python implementation, or the faster, but more resource intensive
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/kward/shflags.git")
+ (url "https://github.com/kward/shflags")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1185,7 +1185,7 @@ lot easier.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/ctmarinas/stgit.git")
+ (url "https://github.com/ctmarinas/stgit")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1237,7 +1237,7 @@ manipulate them in various ways.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/RichiH/vcsh.git")
+ (url "https://github.com/RichiH/vcsh")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1312,7 +1312,7 @@ also walk each side of a merge and test those changes individually.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/sitaramc/gitolite.git")
+ (url "https://github.com/sitaramc/gitolite")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2058,7 +2058,7 @@ output of the @code{git} command.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/0-wiz-0/findnewest.git")
+ (url "https://github.com/0-wiz-0/findnewest")
(commit (string-append "findnewest-" version))))
(file-name (git-file-name name version))
(sha256
@@ -2130,7 +2130,7 @@ Mercurial, Bazaar, Darcs, CVS, Fossil, and Veracity.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/DanielDent/git-annex-remote-rclone.git")
+ (url "https://github.com/DanielDent/git-annex-remote-rclone")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2399,7 +2399,7 @@ how information about the merge is displayed.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mhagger/git-imerge.git")
+ (url "https://github.com/mhagger/git-imerge")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256