summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 953440a6fd..4b78704537 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -186,12 +186,16 @@ as well as the classic centralized workflow.")
,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
- (add-after 'configure 'patch-makefile-shebangs
+ (add-after 'configure 'patch-makefiles
(lambda _
(substitute* "Makefile"
(("/bin/sh") (which "sh"))
(("/usr/bin/perl") (which "perl"))
- (("/usr/bin/python") (which "python")))))
+ (("/usr/bin/python") (which "python")))
+ (substitute* "perl/Makefile"
+ ;; Don't create timestamped 'perllocal.pod'.
+ (("\\$< PREFIX=") "$< NO_PERLLOCAL=1 PREFIX="))
+ #t))
(add-after 'configure 'add-PM.stamp
(lambda _
;; Add the "PM.stamp" to avoid "no rule to make target".
@@ -816,6 +820,7 @@ following features:
"subversion/bindings/swig/perl/native"
(and (zero?
(system* "perl" "Makefile.PL"
+ "NO_PERLLOCAL=1"
(string-append "PREFIX=" out)))
(zero?
(system* "make" "install"