summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm120
1 files changed, 116 insertions, 4 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 36a6b7cd18..38756f06c2 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 André <eu@euandre.org>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -123,14 +124,14 @@ as well as the classic centralized workflow.")
(name "git")
;; XXX When updating Git, check if the special 'git:src' input to cgit needs
;; to be updated as well.
- (version "2.14.1")
+ (version "2.14.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "1iic3wiihxp3l3k6d4z886v3869c3dzgddjxnd5124wy1rnlqwkg"))))
+ "18f70gfzwqd210806hmf94blcd7yv5h9ka6xqkpd2jhijqwp5sah"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -144,7 +145,7 @@ as well as the classic centralized workflow.")
(sha256
(base32
- "1whlsiicayalym4hkf01zdiqpw37gdf7c52gw9ki7bv2x3hf3g3y"))))))
+ "1z05a7hxxndyby3dbj3gaw91sjwmky5d1yph96jmj0fhx78m1lvd"))))))
(inputs
`(("curl" ,curl)
("expat" ,expat)
@@ -552,6 +553,44 @@ collaboration using typical untrusted file hosts or services.")
a built-in cache to decrease server I/O pressure.")
(license license:gpl2)))
+(define-public python-ghp-import
+ (package
+ (name "python-ghp-import")
+ (version "0.5.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/davisp/ghp-import/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0x887v690xsac2hzjkpbvp3a6crh3m08mqbk3nb4xwc9dnk869q7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'install 'install-documentation
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc"))
+ (licenses (string-append out "/share/licenses")))
+ (install-file "README.md" doc)
+ (install-file "LICENSE" licenses)))))))
+ (home-page "https://github.com/davisp/ghp-import")
+ (synopsis "Copy directory to the gh-pages branch")
+ (description "Script that copies a directory to the gh-pages branch (by
+default) of the repository.")
+
+ ;; See <https://bugs.gnu.org/27913>.
+ (license (license:non-copyleft
+ "https://raw.githubusercontent.com/davisp/ghp-import/master/LICENSE"
+ "Tumbolia Public License"))))
+
+(define-public python2-ghp-import
+ (package-with-python2
+ (strip-python2-variant python-ghp-import)))
+
(define-public shflags
(package
(name "shflags")
@@ -639,6 +678,79 @@ subcommands helps automate some parts of the flow to make working with it a
lot easier.")
(license license:bsd-2)))
+(define-public stgit
+ (package
+ (name "stgit")
+ (version "0.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ctmarinas/stgit/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "19fk6vw3pgp2a98wpd4j3kyiyll5dy9bi4921wq1mrky0l53mj00"))))
+ (build-system python-build-system)
+ (inputs
+ `(("git" ,git)))
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; two tests will fail -> disable them. TODO: fix the failing tests
+ (delete-file "t/t3300-edit.sh")
+ (delete-file "t/t7504-commit-msg-hook.sh")
+ (zero? (system* "make" "test")))))))
+ (home-page "http://procode.org/stgit/")
+ (synopsis "Stacked Git")
+ (description
+ "StGit is a command-line application that provides functionality similar
+to Quilt (i.e., pushing/popping patches to/from a stack), but using Git
+instead of @command{diff} and @command{patch}. StGit stores its patches in a
+Git repository as normal Git commits, and provides a number of commands to
+manipulate them in various ways.")
+ (license license:gpl2)))
+
+(define-public vcsh
+ (package
+ (name "vcsh")
+ (version "1.20151229")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/RichiH/vcsh/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ym3swkh738c3vciffvlr96vqzhwmzkb8ajqzap8f0j9n039a1mf"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("which" ,which)))
+ (inputs
+ `(("git" ,git)
+ ("perl" ,perl)
+ ("perl-test-harness" ,perl-test-harness)
+ ("perl-shell-command" ,perl-shell-command)
+ ("perl-test-most" ,perl-test-most)))
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build))
+ #:make-flags (list (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:test-target "test"))
+ (home-page "https://github.com/RichiH/vcsh")
+ (synopsis "Version control system for @code{$HOME}")
+ (description
+ "vcsh version-controls configuration files in several Git repositories,
+all in one single directory. They all maintain their working trees without
+clobbering each other or interfering otherwise. By default, all Git
+repositories maintained via vcsh store the actual files in @code{$HOME},
+though this can be overridden.")
+ (license license:gpl2+)))
+
(define-public git-test-sequence
(let ((commit "48e5a2f5a13a5f30452647237e23362b459b9c76"))
(package
@@ -1263,7 +1375,7 @@ output of the 'git' command.")
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda _
(zero? (system* "autoreconf" "-vfi")))))))
(native-inputs `(("autoconf" ,autoconf)