summaryrefslogtreecommitdiff
path: root/gnu/packages/upnp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/upnp.scm')
-rw-r--r--gnu/packages/upnp.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index ffdebdf1de..22d3f88cd0 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -63,7 +63,7 @@
;; the configure phase.
`(#:make-flags
(list
- (string-append "SH=" (assoc-ref %build-inputs "bash") "/bin/sh")
+ (string-append "SH=" (search-input-file %build-inputs "/bin/sh"))
(string-append "INSTALLPREFIX=" (assoc-ref %outputs "out"))
,(string-append "CC=" (cc-for-target))
@@ -105,7 +105,7 @@ over IRC, instant messaging, network games, and most server software.")
(sha256
(base32 "1b5mnn01cx840paggxrajg63gqzmw8mi4p14jhi9r4qyvam80709"))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(build-system gnu-build-system)
(arguments
;; The tests require a network device capable of multicasting which is