summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index c10b1a5320..f4ae7fbda3 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -164,7 +164,7 @@ living in the same process.")
(define-public gnutls
(package
(name "gnutls")
- (version "3.6.5")
+ (version "3.6.6")
(source (origin
(method url-fetch)
(uri
@@ -176,16 +176,7 @@ living in the same process.")
(patches (search-patches "gnutls-skip-trust-store-test.patch"))
(sha256
(base32
- "0ddvg97dyrh8dkffv1mdc0knxx5my3qdbzv97s4a6jggmk9wwgh7"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; XXX: The generated configure script in GnuTLS 3.6.5
- ;; apparently does not know about Guile 2.2.
- (substitute* "configure"
- (("guile_versions_to_search=\"2\\.0 1\\.8\"")
- "guile_versions_to_search=\"2.2 2.0 1.8\""))
- #t))))
+ "19rcfgsfxb01cyz8jxmmgkjqc7y5s97amajzyknk1i1amywcm6mv"))))
(build-system gnu-build-system)
(arguments
`(; Ensure we don't keep a reference to this buggy software.
@@ -271,7 +262,7 @@ required structures.")
(define-public openssl
(package
(name "openssl")
- (version "1.0.2p")
+ (version "1.0.2q")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -283,7 +274,7 @@ required structures.")
"/openssl-" version ".tar.gz")))
(sha256
(base32
- "003xh9f898i56344vpvpxxxzmikivxig4xwlm7vbi7m8n43qxaah"))
+ "115nisqy7kazbg6br2wrcra9nphyph1l4dgp563b9cf2rv5wyi2p"))
(patches (search-patches "openssl-runpath.patch"
"openssl-c-rehash-in.patch"))))
(build-system gnu-build-system)