summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm32
1 files changed, 24 insertions, 8 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index d9ea0e12c2..9b006a5438 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -117,14 +118,14 @@ expressions.")
(define-public python-pytz
(package
(name "python-pytz")
- (version "2019.1")
+ (version "2020.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytz" version))
(sha256
(base32
- "0hg1r2c41gnmljdsdmdgy6kb1zkfmxsf49imd96g8znp4cyxsiyp"))))
+ "0s72lz9q7rm2xgl2in0nvhn5cp0cyrxa257fpj2919g0s797ssry"))))
(build-system python-build-system)
(home-page "http://pythonhosted.org/pytz")
(synopsis "Python timezone library")
@@ -327,15 +328,20 @@ ISO 8601 dates, time and duration.")
(define-public python-iso8601
(package
(name "python-iso8601")
- (version "0.1.12")
+ (version "0.1.13")
(source
(origin
(method url-fetch)
(uri (pypi-uri "iso8601" version))
(sha256
(base32
- "10nyvvnrhw2w3p09v1ica4lgj6f4g9j3kkfx17qmraiq3w7b5i29"))))
+ "1cgfj91khil4ii5gb8s6nxwm73vx7hqc2k79dd9d8990ylmc5ppp"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv" "iso8601"))))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(home-page "https://bitbucket.org/micktwomey/pyiso8601")
@@ -399,21 +405,31 @@ timestamps.")
(define-public python-arrow
(package
(name "python-arrow")
- (version "0.10.0")
+ (version "0.17.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "arrow" version))
(sha256
(base32
- "08n7q2l69hlainds1byd4lxhwrq7zsw7s640zkqc3bs5jkq0cnc0"))))
+ "1m3fpz96w3g08i9x9cpqh3cr795y9zbj1bfnay3ccdhxv86d227z"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv" "tests"))))))
(native-inputs
`(;; For testing
("python-chai" ,python-chai)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-mock" ,python-pytest-mock)
("python-simplejson" ,python-simplejson)))
(propagated-inputs
- `(("python-dateutil" ,python-dateutil)))
- (home-page "https://github.com/crsmithdev/arrow/")
+ `(("python-dateutil" ,python-dateutil)
+ ("python-pytz" ,python-pytz)))
+ (home-page "https://github.com/arrow-py/arrow")
(synopsis "Dates and times for Python")
(description
"Arrow is a Python library to creating, manipulating, formatting and