summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm64
1 files changed, 28 insertions, 36 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 3284be243e..2d8a104d54 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
@@ -83,32 +83,25 @@ to DOS format and vice versa.")
(define-public recode
(package
(name "recode")
- ;; Last beta release (3.7-beta2) is from 2008; last commit from Feb 2014.
- ;; So we use that commit instead.
- (version "3.7.0.201402")
+ (version "3.7")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pinard/Recode.git")
- (commit "2d7092a9999194fc0e9449717a8048c8d8e26c18")))
+ (method url-fetch)
+ (uri (string-append "https://github.com/rrthomas/recode/releases/"
+ "download/v" version "/" name "-" version ".tar.gz"))
(sha256
- (base32 "1wssv8z6g3ryrw33sksz4rjhlnhgvvdqszw1ggl4rcwks34n86zm"))
- (file-name (string-append name "-" version "-checkout"))))
+ (base32
+ "0r4yhf7i7zp2nl2apyzz7r3i2in12n385hmr8zcfr18ly0ly530q"))
+ (modules '((guix build utils)))
+ (snippet
+ `(begin
+ (delete-file "tests/Recode.c")
+ #t))))
(build-system gnu-build-system)
- (native-inputs `(("python" ,python-2)))
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'pre-check
- (lambda _
- (substitute* "tests/setup.py"
- (("([[:space:]]*)include_dirs=.*" all space)
- (string-append all space "library_dirs=['../src/.libs'],\n")))
- ;; The test extension 'Recode.so' lacks RUNPATH for 'librecode.so'.
- (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/src/.libs"))
- #t)))))
- (home-page "https://github.com/pinard/Recode")
+ (native-inputs
+ `(("python" ,python-2)
+ ("python2-cython" ,python2-cython)))
+ (home-page "https://github.com/rrthomas/recode")
(synopsis "Text encoding converter")
(description "The Recode library converts files between character sets and
usages. It recognises or produces over 200 different character sets (or about
@@ -116,27 +109,23 @@ usages. It recognises or produces over 200 different character sets (or about
any pair. When exact transliteration are not possible, it gets rid of
offending characters or falls back on approximations. The recode program is a
handy front-end to the library.")
- (license license:gpl2+)))
+ (license license:gpl3+)))
(define-public enca
(package
(name "enca")
- (version "1.16")
+ (version "1.19")
(source
(origin
(method url-fetch)
(uri (string-append
"https://github.com/nijel/enca/archive/" version ".tar.gz"))
(sha256
- (base32 "1xik00x0yvhswsw2isnclabhv536xk1s42cf5z54gfbpbhc7ni8l"))
+ (base32 "099z526i7qgij7q1w3lvhl88iv3jc3nqxca2i09h6s08ghyrmzf4"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
- (inputs `(("recode" ,recode)))
-
- ;; Both 'test-convert-64.sh' and 'test-convert-filter.sh' manipulate a
- ;; 'test.tmp' file, so they have to run in sequence.
- (arguments '(#:parallel-tests? #f))
-
+ ;; enca-1.19 tests fail with recent recode.
+ ;(inputs `(("recode" ,recode)))
(home-page "https://github.com/nijel/enca")
(synopsis "Text encoding detection tool")
(description "Enca (Extremely Naive Charset Analyser) consists of libenca,
@@ -519,10 +508,12 @@ in a portable way.")
(add-after 'unpack 'delete-test
;; See comments about the license.
(lambda _
- (delete-file "src/tests/dbacl-jap.shin")))
+ (delete-file "src/tests/dbacl-jap.shin")
+ #t))
(add-after 'delete-sample6-and-japanese 'autoreconf
(lambda _
- (zero? (system* "autoreconf" "-vif"))))
+ (invoke "autoreconf" "-vif")
+ #t))
(add-after 'unpack 'fix-test-files
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -543,7 +534,7 @@ in a portable way.")
("autoconf" ,autoconf)
("automake" ,automake)
("pkg-config" ,pkg-config)))
- (home-page "http://www.lbreyer.com/dbacl.html")
+ (home-page "https://www.lbreyer.com/dbacl.html")
(synopsis "Bayesian text and email classifier")
(description
"dbacl is a fast Bayesian text and email classifier. It builds a variety
@@ -641,6 +632,7 @@ source code.")
(uri (git-reference
(url "https://github.com/aflc/editdistance.git")
(commit commit)))
+ (file-name (git-file-name name version))
(sha256
(base32
"1l43svsv12crvzphrgi6x435z6xg8m086c64armp8wzb4l8ccm7g"))))
@@ -652,7 +644,7 @@ source code.")
(lambda _
(with-directory-excursion "editdistance"
(delete-file "bycython.cpp")
- (zero? (system* "cython" "--cplus" "bycython.pyx"))))))))
+ (invoke "cython" "--cplus" "bycython.pyx")))))))
(native-inputs
`(("python-cython" ,python-cython)))
(home-page "https://www.github.com/aflc/editdistance")