summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm28
1 files changed, 26 insertions, 2 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 9f7cdddcad..537a840247 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Ben Woodcroft <donttrustben@gmail.com>
+;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,7 +41,8 @@
(url "https://github.com/pinard/Recode.git")
(commit "2d7092a9999194fc0e9449717a8048c8d8e26c18")))
(sha256
- (base32 "1wssv8z6g3ryrw33sksz4rjhlnhgvvdqszw1ggl4rcwks34n86zm"))))
+ (base32 "1wssv8z6g3ryrw33sksz4rjhlnhgvvdqszw1ggl4rcwks34n86zm"))
+ (file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system)
(native-inputs `(("python" ,python-2)))
(arguments
@@ -74,7 +76,8 @@ handy front-end to the library.")
(uri (string-append
"https://github.com/nijel/enca/archive/" version ".tar.gz"))
(sha256
- (base32 "1xik00x0yvhswsw2isnclabhv536xk1s42cf5z54gfbpbhc7ni8l"))))
+ (base32 "1xik00x0yvhswsw2isnclabhv536xk1s42cf5z54gfbpbhc7ni8l"))
+ (file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
(inputs `(("recode" ,recode)))
@@ -177,3 +180,24 @@ the Hannon Lab.")
"CityHash provides hash functions for strings. The functions mix the
input bits thoroughly but are not suitable for cryptography.")
(license license:expat))))
+
+(define-public libconfig
+ (package
+ (name "libconfig")
+ (version "1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.hyperrealm.com/libconfig/"
+ "libconfig-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xh3hzk63v4y8815lc5209m3s6ms2cpgw4h5hg462i4f1lwsl7g3"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.hyperrealm.com/libconfig/")
+ (synopsis "C/C++ configuration file library")
+ (description
+ "Libconfig is a simple library for manipulating structured configuration
+files. This file format is more compact and more readable than XML. And
+unlike XML, it is type-aware, so it is not necessary to do string parsing in
+application code.")
+ (license license:lgpl2.1+)))