summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm93
1 files changed, 31 insertions, 62 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index f415fd7f65..924dc68c03 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages code)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
@@ -101,10 +102,6 @@
`("LUA_PATH" ":" prefix (,LUA_PATH))
`("LUA_CPATH" ":" prefix (,LUA_CPATH)))
#t))))))
- (native-search-paths
- (list (search-path-specification
- (variable "VIS_PATH")
- (files '("share/vis")))))
(inputs `(("lua" ,lua)
("ncurses" ,ncurses)
("libtermkey" ,libtermkey)
@@ -196,7 +193,7 @@ bindings and many of the powerful features of GNU Emacs.")
(define-public jucipp
(package
(name "jucipp")
- (version "1.5.1")
+ (version "1.6.0")
(home-page "https://gitlab.com/cppit/jucipp")
(source (origin
(method git-fetch)
@@ -208,7 +205,7 @@ bindings and many of the powerful features of GNU Emacs.")
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "0v7fmsya2zn1xx59bkv4cbyinmcnv52hm4j40nbfwalcks631xrr"))))
+ (base32 "177myy6qvjlb6j3f3i3xmfml5r3p9in8xzpvm0n59dn56s81gpnr"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBUILD_TESTING=ON"
@@ -225,19 +222,6 @@ bindings and many of the powerful features of GNU Emacs.")
(chdir "build")
#t))
- ;; This phase is necessary to fix a test failure, see
- ;; <https://gitlab.com/cppit/jucipp/-/issues/423>.
- (add-after 'unpack 'add-reference-to-clang-internal-header
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/compile_commands.cc"
- ((".*-I/usr/lib/clang.*" all)
- (string-append "arguments.emplace_back(\"-I"
- (assoc-ref inputs "libclang")
- "/lib/clang/"
- ,@(list (package-version clang))
- "/include\");\n"
- all)))
- #t))
(add-after 'unpack 'patch-tiny-process-library
(lambda _
(with-directory-excursion "lib/tiny-process-library"
@@ -269,9 +253,10 @@ bindings and many of the powerful features of GNU Emacs.")
(inputs
`(("aspell" ,aspell)
("boost" ,boost)
+ ("ctags" ,universal-ctags)
("gtkmm" ,gtkmm)
("gtksourceviewmm" ,gtksourceviewmm)
- ("libclang" ,clang)
+ ("libclang" ,clang-10) ;XXX: must be the same version as Mesas LLVM
("libgit2" ,libgit2)))
(synopsis "Lightweight C++ IDE")
(description
@@ -513,7 +498,7 @@ scripts/input/X11/C/Shell/HTML/Dired): 49KB.
(define-public ghostwriter
(package
(name "ghostwriter")
- (version "1.8.0")
+ (version "1.8.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -522,7 +507,7 @@ scripts/input/X11/C/Shell/HTML/Dired): 49KB.
(file-name (git-file-name name version))
(sha256
(base32
- "13yn82m1l2pq93wbl569a2lzpc3sn8a8g30hsgdch1l9xlmhwran"))))
+ "0jc6szfh5sdnafhwsr1xv7cn1fznniq58bix41hb9wlbkvq7wzi6"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -758,14 +743,14 @@ and Octave. TeXmacs is completely extensible via Guile.")
(define-public scintilla
(package
(name "scintilla")
- (version "4.3.3")
+ (version "4.4.3")
(source
(origin
(method url-fetch)
(uri (let ((v (apply string-append (string-split version #\.))))
(string-append "https://www.scintilla.org/scintilla" v ".tgz")))
(sha256
- (base32 "0zh8c19r1zd4kr9jg2ws0n2n5ic2siz5zbns6cvylyfbpf69ghy2"))))
+ (base32 "080v9l7dn3qgkdg0nc0kwpj6warwpi904zjgz9kzg1l6pknxf21s"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list "GTK3=1" "CC=gcc" "-Cgtk")
@@ -773,20 +758,14 @@ and Octave. TeXmacs is completely extensible via Guile.")
#:phases
(modify-phases %standard-phases
(delete 'configure) ;no configure script
- (add-after 'unpack 'build-shared-library
- (lambda _
- (substitute* "gtk/makefile"
- (("scintilla\\.a") "libscintilla.so")
- (("\\$\\(AR\\) \\$\\(ARFLAGS\\) \\$@ \\$\\^")
- "$(CC) -shared $^ -o $@")
- (("\\$\\(RANLIB\\) \\$@") ""))
- #t))
(replace 'install
+ ;; Upstream provides no install script.
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(lib (string-append out "/lib"))
(include (string-append out "/include")))
- (install-file "bin/libscintilla.so" lib)
+ (for-each (lambda (f) (install-file f lib))
+ (find-files "bin/" "\\.so$"))
(for-each (lambda (f) (install-file f include))
(find-files "include/" "."))
#t))))))
@@ -811,17 +790,13 @@ and multiple fonts.")
(package
(name "geany")
(version "1.36")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://download.geany.org/"
- "geany-" version ".tar.bz2"))
- (sha256
- (base32
- "0gnm17cr4rf3pmkf0axz4a0fxwnvp55ji0q0lzy88yqbshyxv14i"))
- (modules '((guix build utils)))
- (snippet '(begin
- (delete-file-recursively "scintilla")
- #t))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.geany.org/"
+ "geany-" version ".tar.bz2"))
+ (sha256
+ (base32 "0gnm17cr4rf3pmkf0axz4a0fxwnvp55ji0q0lzy88yqbshyxv14i"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -834,26 +809,20 @@ and multiple fonts.")
("python-docutils" ,python-docutils))) ;for rst2html
(inputs
`(("gtk+" ,gtk+)
- ("scintilla" ,scintilla)))
+ ;; FIXME: Geany bundles a 3.X release of Scintilla. It is not
+ ;; currently possible to replace it with our Scintilla package.
+ ;; ("scintilla" ,scintilla)
+ ))
(arguments
- `(#:phases
+ `(#:imported-modules ((guix build glib-or-gtk-build-system)
+ ,@%gnu-build-system-modules)
+ #:modules (((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ (guix build gnu-build-system)
+ (guix build utils))
+ #:phases
(modify-phases %standard-phases
- (add-after 'unpack 'use-scintilla-shared-library
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "configure.ac"
- (("scintilla/Makefile") "")
- (("scintilla/include/Makefile") ""))
- (substitute* "Makefile.am"
- (("scintilla ") ""))
- (substitute* "src/Makefile.am"
- (("\\$\\(top_builddir\\)/scintilla/libscintilla.la") "")
- (("geany_LDFLAGS =" all) (string-append all " -lscintilla")))
- (substitute* "doc/Makefile.am"
- (("\\$\\(INSTALL_DATA\\) \\$\\(top_srcdir\\)/scintilla/License.txt \\$\\(DOCDIR\\)/ScintillaLicense.txt") ""))
- (substitute* "tests/Makefile.am"
- (("AM_LDFLAGS =" all) (string-append all " -lscintilla")))
- (for-each delete-file (list "autogen.sh" "configure" "Makefile.in"))
- #t)))))
+ (add-after 'install 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(home-page "https://www.geany.org")
(synopsis "Fast and lightweight IDE")
(description "Geany is a small and fast Integrated Development