summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 18 insertions, 8 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c293d2f661..e67b0505f3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -260,12 +260,12 @@ copied to their outputs; otherwise the TEXLIVE-BUILD-SYSTEM is used."
"&id=" revision))
(file-name (string-append "texlive-bin-" name))
(sha256 (base32 hash)))))
- (arch-revision "e1975bce0b9d270d7c9773c5beb7e87d61ee8f57"))
+ (arch-revision "c4b99aba97213ea554b6592a4916d3c7394a6d7b"))
(append (search-patches "texlive-bin-CVE-2018-17407.patch"
"texlive-bin-luatex-poppler-compat.patch")
(list
- (arch-patch "pdftex-poppler0.72.patch" arch-revision
- "0p46b6xxxg2s3hx67r0wpz16g3qygx65hpc581xs3jz5pvsiq3y7")
+ (arch-patch "pdftex-poppler0.76.patch" arch-revision
+ "15ypbh21amfsdxy7ca825x28lkmmkklxk1w660gpgvzdi7s70h0b")
(arch-patch "xetex-poppler-fixes.patch" arch-revision
"1jj1p5zkjljb7id9pjv29cw0cf8mwrgrh4ackgzz9c200vaqpsvx")))))))
(build-system gnu-build-system)
@@ -316,9 +316,6 @@ copied to their outputs; otherwise the TEXLIVE-BUILD-SYSTEM is used."
`(#:out-of-source? #t
#:configure-flags
`("--disable-native-texlive-build"
- ;; XXX: This is needed because recent Poppler requires C++11 or later.
- ;; Remove after switch to GCC >= 6.
- "CXXFLAGS=-std=gnu++11"
"--with-system-cairo"
"--with-system-freetype2"
"--with-system-gd"
@@ -360,11 +357,24 @@ copied to their outputs; otherwise the TEXLIVE-BUILD-SYSTEM is used."
#t))
(add-after 'unpack 'use-code-for-new-poppler
(lambda _
- (copy-file "texk/web2c/pdftexdir/pdftoepdf-poppler0.72.0.cc"
+ (copy-file "texk/web2c/pdftexdir/pdftoepdf-poppler0.76.0.cc"
"texk/web2c/pdftexdir/pdftoepdf.cc")
- (copy-file "texk/web2c/pdftexdir/pdftosrc-poppler0.72.0.cc"
+ (copy-file "texk/web2c/pdftexdir/pdftosrc-poppler0.76.0.cc"
"texk/web2c/pdftexdir/pdftosrc.cc")
#t))
+ (add-after 'use-code-for-new-poppler 'use-code-for-even-newer-poppler
+ (lambda _
+ ;; Adjust for deprecated types in Poppler 0.73 and later.
+ (substitute* (append
+ (find-files "texk/web2c/luatexdir/" "\\.(cc|w)$")
+ '("texk/web2c/pdftexdir/pdftosrc.cc"))
+ (("GBool") "bool")
+ (("gFalse") "false")
+ (("gTrue") "true")
+ (("getCString") "c_str")
+ (("Guint") "unsigned int")
+ (("Guchar") "unsigned char"))
+ #t))
(add-after 'unpack 'disable-failing-test
(lambda _
;; FIXME: This test fails on 32-bit architectures since Glibc 2.28: