summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm94
1 files changed, 87 insertions, 7 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e4346d1232..10270271c9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6,12 +6,13 @@
;;; Copyright © 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4901,6 +4902,32 @@ fonts. Note that direct substitutes for the bitmapped EC fonts are available,
via the CM-super, Latin Modern and (in a restricted way) CM-LGC font sets.")
(license license:lppl1.3+)))
+(define-public texlive-inconsolata
+ (package
+ (inherit (simple-texlive-package
+ "texlive-inconsolata"
+ (list "/doc/fonts/inconsolata/"
+ "/fonts/enc/dvips/inconsolata/"
+ "/fonts/map/dvips/inconsolata/"
+ "/fonts/opentype/public/inconsolata/"
+ "/fonts/tfm/public/inconsolata/"
+ "/fonts/type1/public/inconsolata/"
+ "/tex/latex/inconsolata/")
+ (base32
+ "1a77w26m4c4j0202s1qkikz7ha6cxlv8zxhzi9s3l0x1l2pl7cr2")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/inconsolata")
+ (synopsis "Monospaced font with support files for use with TeX")
+ (description
+ "Inconsolata is a monospaced font designed by Raph Levien. This package
+contains the font (in both Adobe Type 1 and OpenType formats) in regular and
+bold weights, with additional glyphs and options to control slashed zero,
+upright quotes and a shapelier lower-case L, plus metric files for use with
+TeX, and LaTeX font definition and other relevant files.")
+ (license (list license:lppl1.3+
+ license:silofl1.1
+ license:asl2.0))))
+
(define-public texlive-times
(package
(inherit (simple-texlive-package
@@ -6035,7 +6062,7 @@ values (strings, macros, or numbers) pasted together.")
(define-public biber
(package
(name "biber")
- (version "2.12")
+ (version "2.11")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -6044,10 +6071,11 @@ values (strings, macros, or numbers) pasted together.")
(file-name (git-file-name name version))
;; TODO: Patch awaiting inclusion upstream (see:
;; https://github.com/plk/biber/issues/239).
- (patches (search-patches "biber-fix-encoding-write.patch"))
+ (patches (search-patches "biber-fix-encoding-write.patch"
+ "biber-sortinithash.patch"))
(sha256
(base32
- "1g1hi6zvf2hmrjly1sidjaxy5440gfqm4p7p3n7kayshnjsmlskx"))))
+ "0qgkc1k9n36yfmndwz879pak6mjphld0p85lzn9g2ng0vhxsifzz"))))
(build-system perl-build-system)
(arguments
`(#:phases
@@ -6132,8 +6160,8 @@ other things it comes with full Unicode support.")
"1xbkv8ll889933gyi2a5hj7hhh216k04gn8fwz5lfv5iz8s34gbq"))))
(build-system gnu-build-system)
(arguments '(#:tests? #f)) ; no `check' target
- (inputs `(("texinfo" ,texinfo)
- ("python" ,python-2) ; incompatible with Python 3 (print syntax)
+ (native-inputs `(("texinfo" ,texinfo)))
+ (inputs `(("python" ,python-2) ; incompatible with Python 3 (print syntax)
("which" ,which)))
(home-page "https://launchpad.net/rubber")
(synopsis "Wrapper for LaTeX and friends")
@@ -7066,7 +7094,7 @@ the file to which it applies.")
(home-page "https://www.ctan.org/pkg/pdfx")
(synopsis "PDF/X and PDF/A support for pdfTeX, LuaTeX and XeTeX")
(description
- "This package helps LaTeX users to create PDF/X, PFD/A and other
+ "This package helps LaTeX users to create PDF/X, PDF/A and other
standards-compliant PDF documents with pdfTeX, LuaTeX and XeTeX.")
(license license:lppl1.2+)))
@@ -7168,6 +7196,32 @@ a different path and manipulating characters. It includes the functionality
of the old package @code{pst-char}.")
(license license:lppl))))
+(define-public texlive-marginnote
+ (let ((template (simple-texlive-package
+ "texlive-marginnote"
+ (list "/source/latex/marginnote/marginnote.dtx")
+ (base32
+ "1vj1k8xm11gjdfj60as42d8lsv3dbzrm5dlgqcfk89d9dzm3k39j"))))
+ (package
+ (inherit template)
+ (home-page "http://www.ctan.org/pkg/marginnote")
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "latex/marginnote")
+ ((#:build-targets _ '())
+ ''("marginnote.dtx"))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/marginnote") #t))))))
+ (synopsis "Notes in the margin")
+ (description "This package provides the command @code{\\marginnote} that
+may be used instead of @code{\\marginpar} at almost every place where
+@code{\\marginpar} cannot be used, e.g., inside floats, footnotes, or in
+frames made with the @code{framed} package.")
+ (license license:lppl1.3c+))))
+
(define-public texlive-iftex
(let ((template (simple-texlive-package
"texlive-iftex"
@@ -7388,3 +7442,29 @@ commands as well as behind-the-scenes optimisation. Guidelines are given as
to what constitutes a good table in this context. The package offers
@code{longtable} compatibility.")
(license license:lppl1.3+)))
+
+(define-public texlive-csquotes
+ (let ((template (simple-texlive-package
+ "texlive-csquotes"
+ (list "/doc/latex/csquotes/"
+ "/tex/latex/csquotes/")
+ (base32
+ "15hgn37zg433skn7ijqs1kl2z56fhy29cjxn01b5pjrnrkdar4i4")
+ #:trivial? #t)))
+ (package
+ (inherit template)
+ (propagated-inputs
+ `(("texlive-etoolbox" ,texlive-etoolbox)))
+ (home-page "https://www.ctan.org/pkg/csquotes")
+ (synopsis "Context sensitive quotation facilities")
+ (description "This package provides advanced facilities for inline and
+display quotations. It is designed for a wide range of tasks ranging from the
+most simple applications to the more complex demands of formal quotations.
+The facilities include commands, environments, and user-definable 'smart
+quotes' which dynamically adjust to their context. Quotation marks are
+switched automatically if quotations are nested and they can be adjusted to
+the current language if the babel package is available. There are additional
+facilities designed to cope with the more specific demands of academic
+writing, especially in the humanities and the social sciences. All quote
+styles as well as the optional active quotes are freely configurable.")
+ (license license:lppl1.3c+))))