summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm56
1 files changed, 5 insertions, 51 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d0097313d9..b2c072f694 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2874,54 +2874,10 @@ set default \"driver\" options for the color and graphics packages.")
(base32
"0nlfhn55ax89rcvpkrl9570671b62kcr4c9l5ch3w5zw9vmi00dz"))))
(build-system texlive-build-system)
- (arguments
- '(#:tex-directory "latex/graphics"
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-config
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((cfg (assoc-ref inputs "graphics-cfg"))
- (target (string-append (assoc-ref outputs "out")
- "/share/texmf-dist/tex/latex/graphics-cfg")))
- (mkdir-p target)
- (install-file (string-append cfg "/graphics.cfg") target)
- (install-file (string-append cfg "/color.cfg") target)
- #t)))
- (add-after 'install 'install-defs
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((def (assoc-ref inputs "graphics-def"))
- (target (string-append (assoc-ref outputs "out")
- "/share/texmf-dist/tex/latex/graphics-def")))
- (mkdir-p target)
- (copy-recursively def target)
- #t))))))
- (native-inputs
- `(("graphics-cfg"
- ,(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/latex3/graphics-cfg.git")
- (commit "19d1238af17df376cd46333b229579b0f7f3a41f")))
- (file-name (string-append "graphics-cfg-"
- (number->string %texlive-revision)
- "-checkout"))
- (sha256
- (base32
- "12kbgbm52gmmgn8zajb74s8n5rvnxcfdvs3iyj8vcw5vrsw5i6mh"))))
- ("graphics-def"
- ,(origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/graphics-def"))
- (revision %texlive-revision)))
- (file-name (string-append "graphics-def-"
- (number->string %texlive-revision)
- "-checkout"))
- (sha256
- (base32
- "17zpcgrfsr29g1dkz9np1qi63kjv7gb12rg979c6dai6qksbr3vq"))))))
+ (arguments '(#:tex-directory "latex/graphics"))
+ (propagated-inputs
+ `(("texlive-graphics-cfg" ,texlive-graphics-cfg)
+ ("texlive-graphics-def" ,texlive-graphics-def)))
(home-page "https://www.ctan.org/pkg/latex-graphics")
(synopsis "LaTeX standard graphics bundle")
(description
@@ -2929,9 +2885,7 @@ set default \"driver\" options for the color and graphics packages.")
graphics (e.g. PostScript) files, and rotation and scaling of text in LaTeX
documents. It comprises the packages color, graphics, graphicx, trig, epsfig,
keyval, and lscape.")
- ;; The configuration files are released under CC0.
- (license (list license:lppl1.3c+
- license:cc0))))
+ (license license:lppl1.3c+)))
(define-public texlive-latex-xcolor
(package