summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4500f19292..43901a375e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6829,9 +6829,15 @@ directly generate PDF documents instead of DVI.")
(share (string-append out "/share"))
(texmfroot (string-append share "/texmf-dist/web2c"))
(texmfcnf (string-append texmfroot "/texmf.cnf"))
+ (fmtutilcnf (string-append texmfroot "/fmtutil.cnf"))
(texlive-bin (assoc-ref inputs "texlive-bin"))
(texbin (string-append texlive-bin "/bin"))
(tlpkg (string-append texlive-bin "/share/tlpkg")))
+ ;; LuaJIT is not ported to powerpc64* yet.
+ (if ,(target-ppc64le?)
+ (substitute* fmtutilcnf
+ (("^(luajittex|luajithbtex|mfluajit)" m)
+ (string-append "#! " m))))
;; Register SHARE as TEXMFROOT in texmf.cnf.
(substitute* texmfcnf
(("TEXMFROOT = \\$SELFAUTOPARENT")