summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index adafdfd08b..4e8efc8faf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -161,10 +162,12 @@
"--with-system-zlib"
"--with-system-zziplib")
- ;; Disable tests on mips64 to cope with a failure of luajiterr.test.
- ;; XXX FIXME fix luajit properly on mips64.
- #:tests? ,(not (string-prefix? "mips64" (or (%current-target-system)
- (%current-system))))
+ ;; Disable tests on mips64/aarch64 to cope with a failure of luajiterr.test.
+ ;; XXX FIXME fix luajit properly on mips64 and aarch64.
+ #:tests? ,(let ((s (or (%current-target-system)
+ (%current-system))))
+ (not (or (string-prefix? "aarch64" s)
+ (string-prefix? "mips64" s))))
#:phases
(modify-phases %standard-phases
(add-after 'install 'postint
@@ -3917,7 +3920,7 @@ This package contains the complete TeX Live distribution.")
(define-public perl-text-bibtex
(package
(name "perl-text-bibtex")
- (version "0.77")
+ (version "0.85")
(source
(origin
(method url-fetch)
@@ -3925,7 +3928,7 @@ This package contains the complete TeX Live distribution.")
version ".tar.gz"))
(sha256
(base32
- "0kkfx8skk763pivz6h2ffy2zdp1lvy6d5sz0kjaj0mdbjffvnnb4"))))
+ "036kxgbn1jf70pfm2lmjlzjwnhbkd888fp5lyvmkjpdd15gla18h"))))
(build-system perl-build-system)
(arguments
`(#:phases