summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 637ddb7264..785f05a8c4 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -759,8 +759,7 @@ eye-candy, customizable, and reasonably lightweight.")
"0rm7w29wf3gipf69qf7s42qw8857z74gsigrpz9g6vvd1x58f03m"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.55
- ;; Using a "release" build is recommended both for performance, and
+ `(;; Using a "release" build is recommended both for performance, and
;; also to address a GCC 10 issue when doing PGO builds.
#:build-type "release"
;; Enable LTO as recommended by INSTALL.md.
@@ -1018,14 +1017,14 @@ than a terminal.")
(define-public python-curtsies
(package
(name "python-curtsies")
- (version "0.3.4")
+ (version "0.3.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "curtsies" version))
(sha256
(base32
- "019bpf5wmng4f6ic2ykg893ypfihpfvzi6dhblcagfwbincl79ac"))))
+ "1g8dwafx4vx06isjkn28r3cwb0hw1bv67lgygaz34yk66lrzz1x5"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1035,7 +1034,7 @@ than a terminal.")
(invoke "nosetests" "-v"))))))
(propagated-inputs
`(("python-blessings" ,python-blessings)
- ("python-wcwidth" ,python-wcwidth)))
+ ("python-cwcwidth" ,python-cwcwidth)))
(native-inputs
`(("python-mock" ,python-mock)
("python-pyte" ,python-pyte)
@@ -1402,7 +1401,7 @@ basic input/output.")
(bin (string-append out "/bin"))
(share (string-append out "/share"))
(icons (string-append share "/icons/hicolor/scalable/apps"))
- (tic (string-append (assoc-ref inputs "ncurses") "/bin/tic"))
+ (tic (search-input-file inputs "/bin/tic"))
(man (string-append share "/man/man1"))
(alacritty-bin "target/release/alacritty"))
;; Install the executable.