summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm46
1 files changed, 25 insertions, 21 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 2d15d77524..369e79bf5b 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2016, 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
@@ -71,12 +71,14 @@
(name "tilda")
(version "1.4.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/lanoxx/tilda/archive/"
- "tilda-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lanoxx/tilda.git")
+ (commit (string-append "tilda-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0w2hry2bqcqrkik4l100b1a9jlsih6sq8zwhfpl8zzfq20i00lfs"))))
+ "154rsldqjv2m1bddisb930qicb0y35kx7bxq392n2hn68jr2pxkj"))))
(build-system glib-or-gtk-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
@@ -329,14 +331,14 @@ combining, and so on, with a simple interface.")
(name "picocom")
(version "2.2")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/npat-efault/picocom"
- "/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/npat-efault/picocom.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1knl6dglnrynx1fhy21nylw56i1q3dkizkgxzkq42mb7ilah8f9y"))))
+ "06b2ic34dnxc73cprc5imi3iamlhsv623sbg9vj5h5rvs586dwjx"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("CC=gcc")
@@ -400,13 +402,14 @@ has no notion of what's interesing, but it's very good at that notifying part.")
(version "1.2.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/mauke/unibilium/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mauke/unibilium.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1hbf011d8nzsp7c96fidjiq8yw8zlxf6f1s050ii2yyampvb8ib0"))))
+ "11mbfijdrvbmdlmxs8j4vij78ki0vna89yg3r9n9g1i6j45hiq2r"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -873,13 +876,14 @@ per-line fullscreen terminal rendering, and keyboard input event reporting.")
(version "2.2.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/tmate-io/tmate/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tmate-io/tmate.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "01f3hhm3x0sd6apyb1ajkjfdfvq5m2759w00yp2slr9fyicsrhnr"))))
+ "0pfl9vrswzim9ydi1n652h3rax2zrmy6sqkp0r09yy3lw83h4y1r"))))
(build-system gnu-build-system)
(inputs
`(("libevent" ,libevent)