summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index a4fe97776d..e9e84d2e1f 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -557,7 +557,7 @@ to all types of devices that provide serial consoles.")
(define-public beep
(package
(name "beep")
- (version "1.4.9")
+ (version "1.4.10")
(source
(origin
(method git-fetch)
@@ -570,16 +570,24 @@ to all types of devices that provide serial consoles.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0jmvqk6g5n0wzj9znw42njxq3mzw1769f4db99b83927hf4aidi4"))))
+ (base32 "05c2gxfqc12rgp88c65q7f5ha9gzh222vdh0qpdq1zmyhqj43pq1"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:make-flags
+ `(#:make-flags
(list (string-append "prefix=" (assoc-ref %outputs "out"))
(string-append "pkgdocdir=$(docdir)/" ,name "-" ,version))
#:phases
(modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ (delete 'configure) ; no configure script
+ (add-before 'check 'patch-tests
+ (lambda _
+ (substitute* "GNUmakefile"
+ (("/bin/bash")
+ (which "bash")))
+ (substitute* (find-files "tests" "\\.expected")
+ ;; The build environment lacks /dev/{console,tty*}.
+ ((": Permission denied")
+ ": No such file or directory")))))))
(synopsis "Linux command-line utility to control the PC speaker")
(description "beep allows the user to control the PC speaker with precision,
allowing different sounds to indicate different events. While it can be run