summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 9ee270d875..1cd00f4621 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -76,7 +76,7 @@
(build-system glib-or-gtk-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'patch-source-shebangs 'bootstrap
+ (replace 'bootstrap
(lambda _
(setenv "NOCONFIGURE" "true")
(invoke "sh" "autogen.sh"))))))
@@ -238,7 +238,8 @@ compatibility to existing emulators like xterm, gnome-terminal, konsole, etc.")
"")
;; Replace the call to 'sd_booted' by the truth value.
(("sd_booted\\(\\)")
- "1"))))))
+ "1"))
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -557,7 +558,8 @@ embedded kernel situations.")
"app/qml/ApplicationSettings.qml"))
;; Final substitution for default scanline and pixel fonts
(substitute* "app/qml/ApplicationSettings.qml"
- (("COMMODORE_PET") "PROGGY_TINY"))))))
+ (("COMMODORE_PET") "PROGGY_TINY"))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("qtbase" ,qtbase)