summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm99
1 files changed, 42 insertions, 57 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 4d052dbdaf..f05642a3f9 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -44,20 +44,19 @@
(define-public tcl
(package
(name "tcl")
- (version "8.6.10")
+ (version "8.6.11")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/tcl/Tcl/"
version "/tcl" version "-src.tar.gz"))
(sha256
(base32
- "1vc7imilx6kcb5319r7hnrp4jn5pqb41an3vr3azhgcfcgvdp5ji"))
- (patches (search-patches "tcl-fix-cross-compilation.patch"))))
+ "0n4211j80mxr6ql0xx52rig8r885rcbminfpjdb2qrw6hmk8c14c"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(add-before 'configure 'pre-configure
- (lambda _ (chdir "unix") #t))
+ (lambda _ (chdir "unix")))
(add-after 'install 'install-private-headers
(lambda* (#:key outputs #:allow-other-keys)
;; Private headers are needed by Expect.
@@ -68,8 +67,7 @@
;; Programs such as Ghostscript rely on it.
(with-directory-excursion bin
(symlink (car (find-files "." "tclsh"))
- "tclsh"))
- #t))))
+ "tclsh"))))))
;; By default, man pages are put in PREFIX/man, but we want them in
;; PREFIX/share/man. The 'validate-documentation-location' phase is
@@ -135,9 +133,9 @@
(string-append out "/libtmp") (string-append out "/lib")))
#t)))))
(native-inputs
- `(("tcl" ,tcl)))
+ (list tcl))
(inputs
- `(("tcllib" ,tcllib)))
+ (list tcllib))
(home-page "http://incrtcl.sourceforge.net/")
(synopsis "Object Oriented programming (OOP) extension for Tcl")
(description
@@ -160,11 +158,11 @@ multiple inheritance and public and private classes and variables.")
"0d1cp5hggjl93xwc8h1y6adbnrvpkk0ywkd00inz9ndxn21xm9s9"))))
(build-system gnu-build-system)
(inputs
- `(;; TODO: Add these optional dependencies.
- ;; ("libX11" ,libX11)
- ;; ("xorgproto" ,xorgproto)
- ;; ("tk" ,tk)
- ("tcl" ,tcl)))
+ (list ;; TODO: Add these optional dependencies.
+ ;; ("libX11" ,libX11)
+ ;; ("xorgproto" ,xorgproto)
+ ;; ("tk" ,tk)
+ tcl))
(arguments
'(#:configure-flags
(let ((out (assoc-ref %outputs "out"))
@@ -197,7 +195,7 @@ X11 GUIs.")
(define-public tk
(package
(name "tk")
- (version "8.6.10")
+ (version "8.6.11.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/tcl/Tcl/"
@@ -205,38 +203,31 @@ X11 GUIs.")
version "-src.tar.gz"))
(sha256
(base32
- "11p3ycqbr5116vpaxv6fl6md6gcav1ffspgr8wrlc2lxhn543pv3"))
+ "1gh9k7l76qg9l0sb78ijw9xz4xl1af47aqbdifb6mjpf3cbsnv00"))
(patches (search-patches "tk-find-library.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
- (add-before
- 'configure 'pre-configure
- (lambda _
- (chdir "unix")
- #t))
- (add-after
- 'install 'create-wish-symlink
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (symlink (string-append out "/bin/wish"
- ,(version-major+minor
+ (add-before 'configure 'pre-configure
+ (lambda _ (chdir "unix")))
+ (add-after 'install 'create-wish-symlink
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (symlink (string-append out "/bin/wish"
+ ,(version-major+minor
(package-version tk)))
- (string-append out "/bin/wish")))
- #t))
- (add-after
- 'install 'add-fontconfig-flag
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Add the missing -L flag for Fontconfig in 'tk.pc' and
- ;; 'tkConfig.sh'.
- (let ((out (assoc-ref outputs "out"))
- (fontconfig (assoc-ref inputs "fontconfig")))
- (substitute* (find-files out
- "^(tkConfig\\.sh|tk\\.pc)$")
- (("-lfontconfig")
- (string-append "-L" fontconfig
- "/lib -lfontconfig")))
- #t))))
+ (string-append out "/bin/wish")))))
+ (add-after 'install 'add-fontconfig-flag
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Add the missing -L flag for Fontconfig in 'tk.pc' and
+ ;; 'tkConfig.sh'.
+ (let ((out (assoc-ref outputs "out"))
+ (fontconfig (assoc-ref inputs "fontconfig")))
+ (substitute* (find-files out
+ "^(tkConfig\\.sh|tk\\.pc)$")
+ (("-lfontconfig")
+ (string-append "-L" fontconfig
+ "/lib -lfontconfig")))))))
#:configure-flags
(list (string-append "--with-tcl="
@@ -251,13 +242,12 @@ X11 GUIs.")
;; The tests require a running X server, so we just skip them.
#:tests? #f))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs (list pkg-config))
(inputs `(("libxft" ,libxft)
("fontconfig" ,fontconfig)
("tcl" ,tcl)))
;; tk.h refers to X11 headers, hence the propagation.
- (propagated-inputs `(("libx11" ,libx11)
- ("libxext" ,libxext)))
+ (propagated-inputs (list libx11 libxext))
(home-page "https://www.tcl.tk/")
(synopsis "Graphical user interface toolkit for Tcl")
@@ -279,7 +269,7 @@ interfaces (GUIs) in the Tcl language.")
(base32
"0pha40m97fzafjnq8vwkbi5sml6xv8jki6qi60rxrzmxlrqp5aij"))))
(build-system perl-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs (list pkg-config))
(inputs `(("libx11" ,libx11)
("libpng" ,libpng)
("libjpeg" ,libjpeg-turbo)))
@@ -314,7 +304,7 @@ interfaces (GUIs) in the Tcl language.")
"173abxaazdmf210v651708ab6h7xhskvd52krxk6ifam337qgzh1"))))
(build-system gnu-build-system)
(native-inputs
- `(("tcl" ,tcl)))
+ (list tcl))
(native-search-paths
(list (search-path-specification
(variable "TCLLIBPATH")
@@ -339,10 +329,9 @@ utility functions and modules all written in high-level Tcl.")
"03y0bzgwbh7nnyqkh8n00bbkq2fyblq39s3bdb6mawna0bbn0wwg"))))
(build-system gnu-build-system)
(native-inputs
- `(("tcl" ,tcl)))
+ (list tcl))
(propagated-inputs
- `(("tcllib" ,tcllib)
- ("tk" ,tk))) ; for "wish"
+ (list tcllib tk)) ; for "wish"
(native-search-paths
(list (search-path-specification
(variable "TCLLIBPATH")
@@ -385,11 +374,9 @@ modules for Tk, all written in high-level Tcl. Examples of provided widgets:
(patches (search-patches "tclxml-3.2-install.patch"))))
(build-system gnu-build-system)
(native-inputs
- `(("tcl" ,tcl)
- ("libxml2" ,libxml2)
- ("libxslt" ,libxslt)))
+ (list tcl libxml2 libxslt))
(propagated-inputs
- `(("tcllib" ,tcllib))) ; uri
+ (list tcllib)) ; uri
(native-search-paths
(list (search-path-specification
(variable "TCLLIBPATH")
@@ -438,8 +425,7 @@ callback is evaluated.")
(assoc-ref %outputs "out")
"/lib"))))
(inputs
- `(("tcl" ,tcl)
- ("tk" ,tk)))
+ (list tcl tk))
(home-page "http://tclx.sourceforge.net/")
(synopsis "System programming extensions for Tcl")
(description
@@ -468,8 +454,7 @@ debugging tools.")
(arguments
`(#:import-path "github.com/nsf/gothic"))
(propagated-inputs
- `(("tk" ,tk)
- ("tcl" ,tcl)))
+ (list tk tcl))
(home-page "https://github.com/nsf/gothic")
(synopsis "Tcl/Tk Go bindings")
(description "Gothic contains Go bindings for Tcl/Tk. The package contains