summaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 2f3f191a47..215e8e32cb 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -375,10 +375,10 @@ file system, and many more features.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH"))
- (python-path (getenv "PYTHONPATH")))
+ (python-path (getenv "GUIX_PYTHONPATH")))
(wrap-program (string-append out "/bin/liferea")
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
- `("PYTHONPATH" ":" prefix (,python-path))))
+ `("GUIX_PYTHONPATH" ":" prefix (,python-path))))
#t)))))
(native-inputs
`(("autoconf" ,autoconf)
@@ -434,9 +434,8 @@ a simple interface that makes it easy to organize and browse feeds.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "HOME" (getcwd))
(setenv "TERM" "linux")
- (setenv "TERMINFO" (string-append (assoc-ref inputs "ncurses")
- "/share/terminfo"))
- #t)))
+ (setenv "TERMINFO"
+ (search-input-directory inputs "share/terminfo")))))
#:tests? #f)) ; tests fail: _curses.error: nocbreak() returned ERR
(propagated-inputs
`(("python-beautifulsoup4" ,python-beautifulsoup4)
@@ -600,7 +599,7 @@ that aims to be quite fast and comfortable to its user.")
(add-after 'unpack 'patch-mpv-path
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "gfeeds/confManager.py"
- (("mpv") (string-append (assoc-ref inputs "mpv") "/bin/mpv")))
+ (("mpv") (search-input-file inputs "/bin/mpv")))
#t))
(add-after 'install 'wrap-gfeeds
(lambda* (#:key outputs #:allow-other-keys)